SketchUp does not see internet connection even though IE is up-to-date and using Windows 10

This usually indicates a timeout setting that is too short in duration.

Is that a timeout on the internet, or SketchUp and how do I fix it?

I’ve tried all kinds og things to fix the timeout issue, even going into regedit and add a KeepAliveTimeout, but still no success.

Are you using secure DNS servers by chance ? They could be blocking *.sketchup.com and *.trimble.com websites.

And you have made sure to add these two servers above to your trusted sites list ?
Control Panel > Internet Options > Security > Trusted Sites

If not, add them and try again.

SketchUp uses Internet Explorer for webdialogs. So I would suspect the setting may be related to MSIE. EDIT: The default timeout for the handshake is 15 seconds.
https://msdn.microsoft.com/en-us/library/ee330736(v=vs.85).aspx#websocket_closetimeout

You could test opening another webpage from inside a SketchUp WebDialog frame.

This little script opens the online HTML5 game Bejeweled by PopCap, inside a SketchUp WebDialog frame.
Bejeweled.rb (1.1 KB)

I added *.sketchup.com and *.trimble.com to Trusted Sites. That did not help. I was able to run the Bejeweled script just fine. Do you have the exact script and location I should put it in when I use regedit to add this? Also, Am I shooting for the 15 seconds, or do I want to suppress the time, completely? Also, I will tell you that IE 11 does not load very quickly on my computer. I was wondering if that could be a factor.

I just saw that this Folder is missing: FEATURE_WEBSOCKET_CLOSETIMEOUT Should I add it and a value in it?

Should not be. SketchUp uses the MSIE “WebBrowser Control” which is a library engine (DLL file) that can be used by applications to display web sites in a window frame. It does not load all the toolbars and menus and other junk that the full blown Internet Explorer executable application does.

However,

(1) Do install all updates for MSIE via Windows Update (anytime they become available, even if you normally use some other browser to manually browse the web.)

(2) Clear out your Temporary Internet Files and cookies.
Control Panel > Internet Options > General (tab) >
Browsing History (section) > Delete… (button)

(3) With SketchUp not loaded, delete it’s “cookiejar.xmlandsession.dat” files in folder:

  • %AppData%/SketchUp/SketchUp 2016/SketchUp

(4) In a command prompt run command: ipconfig /flushdns
to flush the DNS resolver cache.

Try again.

Ref:

This is not a folder. This is a registry attribute, in the keypath given in the MSDN article.

If anything, I would only try setting a longer timeout, say 30 seconds.

(I have MSIE 11 on my machine, but this timeout attribute is not explicitly set on my install, so it’s using the default, which seems to be OK.)

Here are command scripts that will add (and remove) the attribute for sketchup.exe setting the timeout.
But since other websites load okay (the bejeweled game,) I think the issue is with the Trimble websites.

But hey it could be worth a try.

sketchup_webdialog_timeout_scripts.zip (803 Bytes)

Ok… Other than dump the Temporary Internet Files and cookies, I didn’t do any of the things you told me. Now, I can access Add location, but there is no button to actually place the terrain in SketchUp.

I have it working, now. We’ll see for how long.

Thanks Dan!

Drag the right frame of the window larger. (The button is hidden “off screen”.)

I’m having a similar problem that has recently occured after years without a problem.
Sketchup Pro 2016, Windows 10, Internet Explorer 11.

I repaired SU with admin priviledges, Win10 is up to date, IE has javascript working, with medium security settings, and I can connect to 3dwarehouse.sketchup.com/ and https://www.trimble.com/ from it. From the Sketchup Help menu I can connect to everything, including License, except Check for Update which gives an “unable to obtain the latest version information. (possibly a different issue)” Attempting to connect to the 3D Warehouse results in “Could not connect to the 3D Warehouse.” I get a similar error when trying to connect to the Sketchucation Extension Store. Likewise geo-location is a no-go.

I’m having a similar problem that has recently occured after years without a problem.
Sketchup Pro 2016, Windows 10, Internet Explorer 11.

I repaired SU with admin priviledges, Win10 is up to date, IE has javascript working, with medium security settings, and I can connect to https://3dwarehouse.sketchup.com/ and https://www.trimble.com/ from it. From the Sketchup Help menu I can connect to everything, including License, except Check for Update which gives an “unable to obtain the latest version information. (possibly a different issue)” Attempting to connect to the 3D Warehouse results in “Could not connect to the 3D Warehouse.” I get a similar error when trying to connect to the Sketchucation Extension Store. Likewise geo-location is a no-go.

This a home machine with no proxy’s. I’ve attempted to connect with Windows Firewall off and on. I’ve added firewall inbound port rules to allow ports 80, 8080, and 443. I’ve edited the i18n.dat file so ONLINE_TEST_URL=http://cisco.com. I’ve disabled virus protection. I’ve emptied the browser cache, deleted cookies, and flushed the dns cache. I’m not using a secure DNS server, and *.sketchup.com and *.trimble.com are trusted sites. I’ve deleted cookiejar.xml, but there was no session.dat file. I’ve followed all of the steps in http://help.sketchup.com/en/article/3000056.

It’s odd that this behavior occured out of the blue. The only thing I’ve done recently that might account for it was disabling the World Wide Web Publishing service and installing Wampserver instead. I tried connecting with Wampserver on and off as well. No luck.

Can you reverse these steps and see if things return to normal ?

And for Pro edition running network licenses:


SketchUp Help Center

Apologies for not replying sooner. I’ve been traveling. This problem remains unresolved and is monumentally vexing. I’ve performed all of the previous troubleshooting steps again and have enabled WWW Publishing with the same results - “Could not connect to the 3D Warehouse.” IE loads https://3dwarehouse.sketchup.com/ without a problem.

Probably your firewall blocks SketchUp from accessing the Internet.

Anssi

See his previous post on things he tried, regarding the Firewall:

http://forums.sketchup.com/t/sketchup-does-not-see-internet-connection-even-though-ie-is-up-to-date-and-using-windows-10/21559/26

Anssii, I’ve already tried with new firewall rules and also with it disabled.

So I resorted to the nuclear option and did a fresh install of Win10. I’ve been meaning to do it anyway as the update from Win8 had made a hash of it. I reinstalled SU and was disappointed to see that it didn’t fix the problem. I reviewed all of the forum suggestions and then uninstalled and reinstalled SU as ADMIN. Happily, this fixed the problemI

Note that before the fresh Win10 install, I had previously reinstalled SU as ADMIN and it did NOT fix the problem. I can only conclude that something had changed in the previous Win installation that caused the problem with SU. Regardless, I find it beyond odd that SU now requires and admin installation, and that I could always connect to the 3D Warehouse etc. with Internet Explorer, even when SU could not. I call that a bug.

The instruction page for a Windows install has always said to “Run as administrator” for Vista and higher. (Ever since UAC and non-user folders required higher privileges.)