SketchUp (desktop version) thinks you don't have an Internet connection

I don’t see the need for a new topic.
Before your subject specificity change, the problem and the error message are the same regardless of whether web or desktop.

If you feel the need to start a new thread for the web version then of course please do so. But it should include a solution too of course.

Then perhaps is a better out-of-the-box option given how many reports there are of problems with the bing check. Of course the argument could also be made that with the move away from the free product, some small part of that funding could be used to support the check that you have forced inside your own product.

No of course those settings are not available for the web version. And yes exactly, of course if the user can access then their internet connection is de facto working. Which is why I have pointed out that building in a connectivity test in the web version is stupid. Especially when that connectivity test is more likely to fail because of your poor choice of target host. And even more especially when the user cannot change it. The check in the web version should be removed.

You’re right, the category and title did not specify the platform, so thank you for pointing that out.
Nevertheless, if you want to talk about an error message for the web version and get replies about that, now that we’ve clarified, you will need to start a new thread. It’s how we can best help you and everyone else. Even if your topic is related to this one, the web conversation doesn’t likely help the people getting these specific error messages on the desktop, so it’s better to start a new thread for that new audience.

Given that a member of the SketchUp team saw fit to start this thread for this known issue with the desktop version, it would seem to follow then that a member of the SketchUp team should start a thread for the same known issue with the web version.

And of course it would make sense for the product team simply to fix the underlying problem rather than rely on users implementing workarounds.

There is something about this topic that I should point out. This is a post about a known issue, in a special page in the forum. It isn’t really intended to be a discussion, though some of the follow up comments helped me to refine the post.

For the web issue you’re seeing, the normal steps would be that people would report the issue (as its own new topic), me and others would figure out what is going on, and then make a known issue post. At the moment I don’t know what errors you are seeing, and so can’t easily say whether it’s a known issue.


A post was split to a new topic: Add location in web version of SketchUp is not seeing an Internet connection

Thanks for the details in your last post. I made it be a new topic, here:

I will ask the web developers to read your post, and hopefully they will fix the issue.

Someone is always the first! I actually am not familiar with what you’re talking about, but I’m very intrigued, and would love to read all about it on the new thread that Colin created for you. Please upload a screenshot in that new thread link.

Thanks! This is very helpful. Got it fixed…

Updating this this small line did the trick for my SketchUp Pro 2018 on the old MacBook with Mojave 10.14.6.

Thanks Colin!

Thanks for the update!

Thanks, Colin. Once I adjusted the administrator settings for the file the fix worked.

Thank you TDahl !!! I can’t thank you enough for posting this reply that got me the quick fix I REALLY needed right now. So appreciative… thanks!

When I try to open the dat file on the desktop this Dell Support assist window opens. How do I get around that? Turn it off? If I click on it, nothing happens. I have a question - why bing? Why won’t chrome or edge work? Thanks G PS I have 2018 pro on a dell XPS

You must open the file with an editor - like notepad :slight_smile:

You know, the whole idea of having your customer fix your product is kinda bogus. How long would it have taken a programmer to write a fix and issue it? It’s nickel and dime stuff like this that irks your customer base. Excuse my mini rant.

Thanks for suggesting to me to use note pad. Note pad is a program I haven’t used in many years, and wasn’t aware how to run it as an administrator, so I googled that, and when https// didn’t work, I tried which did. Signing out and relogging back in finally sorted it. Amazing Trimble never fixed this bug in pro 2018.

Thanks to the several people on this thread and the thread about the dat. file for their time posting stuff about this nonsense. I was ready to pull my hair out, so everybody’s help is appreciated.

The issue has been fixed. This thread is about very old versions of SketchUp.

Right, but why wasn’t a fix sent out back then? Since when was a 2018 very old? Many don’t want the subscription model and use those programs. G

It worked back then.

The issue is that the OS, or network settings, or Google, have made changes that block Sketchup’s attempt to see if is online. The URL that gets checked was changed to around the time of 2019.2, I think mainly because all of China was blocked from using SketchUp. So, few recent version users will see a problem, only if in their case IT have blocked

But, it would be reasonable if SketchUp had a preferences setting where you could choose whichever URL you wanted to check. Or the solution I would do is to go ahead and check or, etc, and it is likely to work. If it doesn’t, then SketchUp could say that you appear to be offline. That way it wouldn’t matter if or were blocked, you would still be able to get to the SketchUp feature you’re trying to use.

Agree. That would be far better than sending users off to find and then edit the .json files manually.