SketchUp crashing, can't save file

I needed to do a project in SketchUp, so it is my first time using the programme.The project is almost done, i only need to add a few things. The problem is that SketchUp crashes constantly. When i click something it crashes, when i try to save the file it crashes. I literally can’t do anything anymore.
I think it is because the file contains a lot of houses etc i got from the warehouse.
Because i’ve never worked with this programme, i really have no idea where to start…

First step would be to go to Window>Model Info>Statistics and click on Purge. does that help?

The second thing would be to start looking at the components you got from the 3D Warehouse. Possibly one or more of them has issues. Perhaps they are bloated with elements you don’t need.

When it crashes, are you getting Bug Splats? Are you sending them in?

Purge didn’t do anything, allready tried that.

The thing about looking for the components, is that i can’t… When i open up the program, i can click my mouse like 3 times and than is just stops working, can’t do anything, no crash reports. The only thing i can do is close it and try again.

Hmmm… Another thing that is often the culprit is the graphics drivers. Radeon drivers are notorious for less than adequate OpenGL performance. Try updating the drivers anyway and see if that helps.

How big is your model file?

it’s 222MB

That’s a pretty big file. Again, check that your graphics drivers are up to date.

From what you describe, I think you mean that the program becomes unresponsive (spinning busy wheel and “not responding” message from Windows), as opposed to crashing per se (program spontaneously closes itself and vanishes)? Unresponsiveness would suggest that something in the model is overwhelming SketchUp. Have you waited a long time to see whether it eventually recovers? Does it do this with all models, or only with your huge one?

In addition to what DaveR has mentioned, it is possible that some extension is the culprit. Try turning off all your extensions and see whether the problem goes away. Doing this is easier if SketchUp will run on a minimal model, as you can use the Extension Manager to disable ones installed using it, and the SketchUcation plugin store tools to disable other ones. Failing those, you could rename the Plugins folder temporarily to prevent extensions from loading. If SketchUp can handle your large model with extensions turned off, you can investigate the model for excessive details etc to reduce its size and complexity, save the edited version, and later turn extensions back on one-by-one until you find the offender.

Yes, unresponsive is what i meant! I have waited a long time and doesn’t recover…
My graphic card driver is up to date.
I only have this huge model, so i can’t compare, but the unresponsiveness only began when it was allmost finished.
How do i turn off all the extensions? Iv’e never worked with this programme so i really don’t know a lot about it…

Here is some information on enabling/disabling extensions:

How did you confirm that your graphics card’s driver is up-to-date? Did you use Windows Update or Device Manager? You may want to check the card or computer’s websites to see if there’s a more recent version.

Mark Chandler

How long is ‘a long time’? I’ve worked on a 210MB model, and it takes around a minute to open on a fast iMac with i5 3.3GHz Intel chip and 24GB RAM.

What processor chip does your Windows machine use, and how much RAM have you? If not a lot of RAM, it may be doing almost endless swapping out to disk, which will make it VERY VERY slow even to load the model.

And Radeon graphics processors don’t have the best support for Open GL

It’s possible your machine is just overwhelmed by the file size and/or number of edges in your model, especially if you have imported a lot of overdetailed models. See a previous thread about simplifying 3Dwarehouse models that have insane numbers of edges for use as sub-models.

Could you upload your model to the 3Dwarehouse and provide a link here, and I’ll see if I can load it on my machine without freezing indefinitely?

I can’t upload it, because it’s too big… could i send it to you in an other way?

I think i turned off the extensions, but nothing visibly has happend… After turning them off, i was able to work on the model a bit, but now it’s again unresponsive most of the time…

Sorry, I’d forgotten there’s a size limit on the warehouse, though I don’t remember what it is, even when reminded that there is one.

You could use Dropbox or Google Drive - both are free to sign up for and use, if you haven’t already got an account with either. Then post a link here.

I suspect it’s the edge count from all the 3D warehouse models. Can you work for long enough to put some of them on a separate layer, and turn it off? That made our 220MB model just manageable, before I finished simplifying the over-detailed components.

The problem is solved.
I just copy pasted the model into a new file. The new file was ‘only’ 110mb, and I was able to complete the work…
Thanks for all the help everyone!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.