Sketchup can not import 3dwarehouse items

I have sketchup pro trial 2021. I tried to import items from 3dwarehouse but no models showed after I clicked download to current sketchup model. when I try to download them from new blank sketchup page they do appear. Why is this happening and how can I fix it?

hello, you might want to look carefully at the size of your drawing. If it’s really tiny of really big, you’d probably think nothing imports from the 3d warehouse, but it’s just that it would be a very different scale and make the imported object not visible (or difficult to spot)

If you import a chair, make sure you import it in a room with decent dimensions for example.

First thing to check is the unit you are using in your model and give realistic dimensions to what you design

shift + z is a useful shortcut to the zoom extents tool. use it after importing an object in your scene if you still have troubles

1 Like

Thank you for your advice.
Like you mentioned I think it’s the size. I thought my settings were in mm but it’s in meters.
Is there a way to change entire design into mm setting instead of drawing the whole thing again?
Thank you for your answer

Hello,
Select all (CTRL+a) then type “s” for scale, grab a corner, type 0,001 and hit enter

I use Web for quite a while, so I have found I fix to changing the length settings.
I am new to Pro, so I don’t know, but I am sure there’s a fix which I do not know of.
Anyways, go to Model Info > Length Units > Formats and change from 0.0m to 0.0mm.

OK, maybe you could start from a new template in mm and load your model (in meters).

Wow. Thank you so much~
I think it’s finally in right size.
By the way, if I try to get close to the building certain angels look like it’s cut off when i move around.
Wonder why it’s happening. Do you by any chance know how I can fix that?

Thank you for your information.
If I have new mm template and move my model from meter, I would have to shrink them, right?

In the pro version, it’s in window > model info > units.
But it’s not going to change the model size, he would have to resize it anyway.

this is clipping, see this help page : Clipping and missing faces | SketchUp Help