Sketchup Broken

I’ve been using Sketchup Make for three years now for several large projects and never faced any problems like this before. Currently, I’ve been working on some small projects and noticed it’s been very temperamental. When I go to move a simple object or rotate my view, the screen flashes black and the toolbar goes black but then reappears when I hover over with the cursor, basically making it impossible to work. Another glitch that came up was the model freezing but I was still able to select different tools.

I’ve tried to work on another project hoping to see that maybe there was something wrong with the first model but the same happened there, so I’m not even sure what’s causing the actual problem. I’ve tried to do all the basics, switching my computer on and off, reinstalling SketchUp as well as clearing up some memory on the computer but nothing seems to be working. Any advice would be very appreciated!!

  1. If you are using SketchUp Make for your work, as it sounds, you must switch to SketchUp Pro. Make is only licensed for hobby use.
  2. You could try switching off Fast Feedback from the Window menu>Preferences>OpenGL window. Also make sure that you are using the latest driver for your graphics chip, from the Intel website.
1 Like