Sketchup automatically undoes a step when I use ctrl+s[ave]

I am experiencing wired situation here. Sketchup will automatically undo a step while I press press save “Ctrl+S”. I had uninstall and reinstall but no chance to get it right. I seek experts assistant.

do you have auto correction enabled in the settings? for one or all models?

Hi Cotty, I am using default setting. I not sure of auto correction settings. Need your advise.

Are you sure you are hitting ctrl s and not ctrl z, as ctrl z is undo and on many keyboards they are only one key apart.

I’m away from a computer, but there should be something like “auto correct errors” and “ask before correction”…

Appreciate.