SketchUp animations no longer sync to my iPhone

I have made loads of little mp4 animations, for various projects i’ve worked on, and like to keep them in job folders, in Photos on my iPhone and on my iPad. They were all made in SketchUp Pro, various versions going back five years or so, and up to the current v.21.0.392.
But it has stopped working. I don’t think SketchUp changed anything, and the files still work on my Mac. But When i try and sync Photos albums from my Mac to my pone or iPad, i get messages saying some files weren’t exported because they are not compatible. After digging around its clear that it is refusing to sync any of my animation files, which are all in mp4 format.
It does sync videos taken on my phone however, which are also in mp4 format. Clearly there is something different about the animation mp4 that Photos or iOS now doesn’t like. But it USED TO BE OK - a year ago things synced, and now this same files don’t sync. So it not SketchUp.
Yes, I know, don’t ask here, go moan at Apple. Yes I am, but getting nowhere. Does anyone else know what I’m talking about and maybe, just maybe be able to offer advice?!

A quick web search found that this is a known issue: the iPhone and iPad will only play certain video file versions and will refuse to sync other video files. iTunes has an option by which to convert to compatible format, though reportedly it loses quality and generates huge files. There are also some non-free apps to do the conversion. I can’t recommend any of them as I haven’t tried them.

That would be good - can you clarify where the option is to convert files in iTunes - i can’t even see the videos in iTunes / Music, they don’t appear at all - maybe you mean Photos? - and is this on the iPhone version, on a mac or on the PC version. I’ve looked on Mac and iphone and don’t see any converters (i’m on the latest version of everything - could it be that earlier versions had this and its been taken out in an update?)…
confused but keen!

I’ve been trying to fix this for weeks without success. Several hours on the phone to Apple support, and as yet they haven’t found a solution.
I’m unclear about it being a known issue. I agree that iPads and iPhones will not play all video formats. There are hundreds. But they will play H.264, MP4, M4V, MOV, MPEG-4 and M-JPEG without any kind of conversion or third party app.
But SketchUp only exports H.264. So it should work. And as i said it used to work.
I’ve tried “Total Video Converter” to change files to the other supported formats, again without success.
So the problem is either the iPad, the cable, the Mac, or the SketchUp export. And after checking and checking and checking, and contrary to my message above, i beginning to think its not any of the first three…
So my question is, has anyone else had success, making an animation in SketchUp Pro, putting the resulting MP4 file into Photos, and then syncing it successfully with their iPad?

If it works for you, please let me know…

i guess that’s a ‘no’ then ?!

You may want to take this to an Apple forum to look for help… once the animation is created, SketchUp does not have much involvement… and most of the users here are here to help with the SketchUp piece.

Thanks for the reply, its just that this used to work for me, and it now doesn’t. And its really important for my work!!
I’ve tried and tried with Apple but they say that as it only happens with Sketchup-produced animations (all other mp4, mov files work ok) it must be something in the way Sketchup makes the video.
So its Sketchup, or its Apple, or its just my machine…!?! …my question is just trying to narrow it down…
I just hoped that someone else was doing the same thing, either successfully or unsuccessfully, so I’d be able to see more clearly where the problem is.
(love your videos by the way!!!)

That is odd! My comment was not saying that you should not ask or anything… I just did not want you to be waiting on feedback for something that very few here may actually have info on.
(and thank you!)

Apple have come back to me with what sounds like sensible logic… though not a solution.
They say that that somewhere within the .mp4 ‘container’, which is made when SketchUp creates an animation file, there is some old 32bit stuff.
I don’t pretend to really understand this, but they say that as more people are using the Cloud these days, rather than cable syncing from Mac to mobile device, so most people won’t have problems because this won’t affect cloud uploads and downloads. And while the file works on my Mac, on my Phone and on my iPad, it’s the sync by cable process that now has problems, going back as far as the launch of Catalina OS, which sounds like when my problems started.
So they agree that they have caused my problem by launching Catalina OS, which is all 64bit, but also that if the SketchUp .mp4 files didn’t still contain some old 32bit bits (!), they would work.