SketchUp and macOS High Sierra

The exact same thing is happening to me. The “Colors” list is now “Colors (1)”, and what seems like random ordering for every material list – not just colors.

MacBook Pro, 13", early 2015, 2.9 GHZ i5, 16 GB RAM, Intel Iris 6100 graphics.

It’s not random - it loads the same way every time. It’s more of a file system thing, from what I’ve discovered: if you do ‘ls -f’ on those colors directories, you get the order that they get loaded in. This happens on some, not all, APFS-formatted High Sierra disks I’ve seen. Still investigating why it loads in an unordered fashion instead of ordered. And it affects ALL versions of SketchUp (2016, 2017) that I’ve seen, so it’s not likely something we did, unless we’re using a deprecated call.

For example, on some APFS or HFS+ machines, if I list the Colors in a bash shell using ls -1f | head

I get
Color A01.skm
Color A02.skm
etc…

On other machines, I get what you’re probably seeing:
Color B03.skm
Color H08.skm
Color F07.skm
Color D05.skm
Color D04.skm
etc…

Is that the order you’re seeing them in? (hover over the color with your cursor and see the name of the material) The order I got matches @colin 's images above.

Huge mistake upgrading to High Sierra. I wish I would have read this forum first. On my system (Mid 2010 MB Pro with 16gb of RAM, 1TB hard drive, everything else stock)…basically Sketchup wont work.

The program launches, I open my file, I move the view around with my 3D mouse, then as soon as I click on any of the tool windows (like layers, scenes, etc)…bugsplat.

I tried multiple files or even starting from a fresh file with nothing in it but the little man…click on any tool window and Sketchup goes away.

I backed up my system a while back on time machine…I’ve never used time machine so I don’t even know how that works. Hopefully either Sketchup catches up with High Sierra or I can get myself back to the previous OS

…no more BETAs for me

I use SketchUp on High Sierra daily no troubles. LayOut’s a different story. What 3D mouse, Connexions? I’ll look up your Bugsplats if you PM me, and we’ll see what’s causing it.

M3 (17.3.116) f. macOS (supporting ‘High Sierra’) claimed to be released, nothing in the release notes or at the blog, yet… run the update check from inside SU or simply download.

1 Like

Barry, thank you for the quick reply

Here’s where I’m at, I completely uninstalled all SketchUp software from my Mac. I downloaded a fresh copy and reinstalled. Since then, I have not experienced any issues with either SU or LO.

The 3D mouse that I use is the connexion. It appears to work fine as well.

I’m happy to send over the bugsplat file or whatever needs to be done if you would still like to see it so that it might help others. Either way, it appears, for the time being at least, that I do not have any issues anymore

OK, well, if it works now, it was probably spurious. If you wanna send me the bugsplat crash # or any other info, I’ll check. But no worries - glad you’re working.

So, the official statement is we should still wait with upgrading to High Sierra, right?
Any idea on when it will be supported?

Maintenance release 3 was turned loose two days ago. It is updated for Sierra. You could install that latest release and see how you go.

1 Like

Great thanks DaveR! I tried to find release notes for the latest update. Do you know where to find them?

I haven’t looked for them but I guess I’d search Release Notes in the Help articles.

We flipped the update, so if you launch SketchUp 2017 and click SketchUp->Check for Update, it should provide a link to Download All | SketchUp

How is there no release notes???

2 Likes

Thanks!

above:

Thanks, High Sierra it is then.

Hello, could you please check my Bug Splat Report?
I am running SU Make on 2016 MacBook Pro and made the update for High Sierra some days ago. It worked fine until today, it suddenly crashed during drawing. Now it won’t start again.
#65135

Thank you

You will need to download the M3 release of SU 2017 Make, which you can find here: Download All | SketchUp

2 Likes