Sketchup 22 - extensions not responding

Hello all,
I can install all my extensions just fine, and everything appears to be good, with extension buttens showing and all. But when i hit a butten , nothing happens!

example: i wanna use “joint push pull” i select the object i want to push/pull, then I hit the button, and nothing happens.

enyone else have experienced this?

all the best Karl

Did you remember to install the LibFredo helper extension too?

Hi Anssi,
is that the same as LibFredo? if it is, then it is installed…
I have never had trouble with this before.

All extensions on the screenshot are “Disabled”… that could be the case of not working… :wink:

2 Likes

Lol thats a good point :wink: Sorry…

Even with all extensions enabled, its still the same issue…buttons are not respinding. so strange.

Have you bought a license?

1 Like

Did you restarted Sketchup after you enebled?

Yes i ave restarted and I have licenses to the extensions that need them

Can I upload a video in here somhow?

Yes, if it is not too big you can do similar way as a screenshot.


Did you get some error message if you open the Ruby Console and keep open during trying joint push pull.

I’ll ping @Fredo6 as it seems to be his plugins that you are having issues with.

Have you installed the latest version of
SketchUcation Toolset [v4.2.5] → SCF licensing dialog version as 5.4a
LibFredo [v12.8a]
etc
and restarted SketchUp afterwards ?
Then checked the validity of each of the licensed extensions…

Also please repeat what you show in your video with the Ruby Console open - that might include error messages