Sketchup 2023 silent crashes when opening file

Just downloaded newest version of '23 Pro and files (both new / template and previous) crash immediately… white window and then crash. Following steps taken ::

  1. all graphics up to date.
  2. uninstall + reinstall
  3. run as admin.
  4. no dock / monitor issues.

To no avail. Please advise.

Do you have extensions installed?

Not anything out of the ordinary… are there certain ones I should be aware of that are causing this sort of issue?

A white window in Windows could mean the graphics driver is out of date. Do not rely on Windows to say it is up to date, go to the manufacturer’s web site to get the latest drivers. ie intel, nvidia, amd

Yes. Went directly to Nvidia. All up to date.

Does a previous version run on your hardware?

Yes, I am having same issues since 2022 version. Just installed 2023 and still having Not Responding issues. Choose to wait on program to “catchup”, hour later still waiting! Terrible bug!
2021 version works fine…

Do you use a Space Mouse?

No space mouse… fairly standard usb setup.

Not sure… I was previously using SUP Pro '23… then got a notification for a ‘newer version’… downloaded it and now having this issue… So, I was previously running sketchup fine until this new ‘update’. If I cant get this resolved in a fairly timely fashion then I might try to download '22… however, all of my models are in '23.

All versions after 2021 use a universal file , so that doesn’t matter so much

Could still be worth checking if 3dx drivers were ever installed. The one time I saw the same crashing you are seeing it was because of having an out of date driver.

Hello Shane, did you solve the problem? The exact same thing is happening to me, everything worked perfectly until I did the last update.
I also checked the other drivers and its all updated.

No solution yet. Im at a little bit of a loss. I double checked drivers. I even went as far as to ensuring BIOS is good… installed updates there as well. Not sure what to do. Might try downloading 2022 as an emergency path. I’ve read a similar entry that states it might be tied to C++… again, at this point it is a guessing game but going to investigate further this evening.

Try redownloading the offline installer.
Reboot machine to clear out memory.
Run the installer “as administrator” (via context-click)
Choose the Repair option.
Reboot machine again.

Thanks for the suggestion… ran through this step by step… still exact same issue happening.

1 Like

Update… Downloaded v.2022 and it works. Not sure if that helps the diagnosis but any help is appreciated.

Same problem here, has a solution been found other than what is written above?

Same problem here. I have tried everything I could think of

Do you use a 3D mouse? Old drivers for the mouse can provoke some crashes.
Also some extensions can have the same effect.