SketchUp 2019 Rectangle tool defaults to start on center

After upgrading to 2019, whenever the rectangle tool is selected, it defaults to start on center instead of a corner. Is there anyway to change this?

What may be throwing you is that the toggle between corner and center is “sticky” until you restart the rectangle tool or press ctrl (option on Mac) again. It should start as corner when you restart the tool, however.

The sticky behavior is what I expect. What I’m getting is the tool always starting from center, regardless of what it was last.

That is odd. I know there isn’t a user-accessible preference setting that controls this, but perhaps there is an undocumented one? Anybody know of such a thing?

What about some of the other functions that the control key affects. are they normal?

Since the OP is on Mac, it is the Option key that toggle’s the startpoint. How do you activate the rectangle tool? Does hitting R acts the same (after a restart)

I have Option+R assigned to activate the tool, so I changed it back to R and now the center/corner behavior works. But I use Option+something for several tools and rectangle is the only one that’s a problem.

My guess is that it’s using your Option keystroke to cause the tool to default to center scale. I highly recommend changing the shortcut to a simple one-key keystroke and see if that fixes the issue.

With a two-key chord shortcut, it could come down to a tiny timing issue that makes SketchUp think it saw the R and then a split second later the opt, causing the too to toggle. Pretty fussy if that’s the case, but not impossible.

1 Like

This does seem to be the case. It’s a new behavior in SU2019 then, because I’ve had that shortcut assigned since at least SU2017.