SketchUp 2017 Pro running ridiculously slow compared to 2016

2017
slow
toolbar

#1

I recently upgraded from Sketchup 2016 Pro to 2017, and immediately noticed it’s running incredibly slow, even on a blank scene. It is using the NVidia card I have installed, and not any on-board graphics.

Briefly, my system specs:
Core I7 4770
16gb RAM
Windows 7
NVidia GTX 770 Titan

My IT department also has something called a “Dameware Mirror Display Driver” installed for remote system access, but I doubt that’s responsible.

I noticed that if I delete the plugins directory for Sketchup 2017, it runs very smooth. As soon as I start adding plugins and toolbars back in, I can watch the processor usage go from 3% to nearly 100%, increasing as each plugin is added back. It appears that Sketchup 2017 is using processing power to run each and every toolbar. Sketchup 2016 does not have this problem, and I’ve had to revert back to 2016 since 2017 is unusable at this rate.

Is there a “Hide all toolbars” button or some way to get Sketchup to stop cranking out so much processing power just to show toolbars? It’s a bit annoying that I just put out so much money for an upgrade I can’t even use.

Please, before you tell me “stop using so many plugins”, I use all of them very heavily and am not going to close them all just to be able to use vanilla Sketchup. Plus, they work fine in 2016 so it’s a moot point.


#2

You can hide or show whatever toolbars you wish.

Make sure the Nvidia Control Panel is set to use the GTX 770 for SketchUp, LayOut and Style Builder (and not the 4th generation integrated Intel GPU.)

Update to the latest Nvidia GeForce Driver.

See if there are any particular plugins causing issues using binary elimination.


#3

I have the latest NVidia drivers, and my system does not have an integrated video card. The slowdown is not related to any single plugin, as it appears that the more plugins that are added, the slower it goes.

As for hiding the toolbars, what shortcut key is that? I know I can turn off individual toolbars, but that’s not what I’m asking. I was looking for a global “hide toolbars” or “clean screen” mode, similar to Adobe or Autodesk products.

I’d really like to know why the plugins are slowing down my system but only in v2017.


#5

I don’t think there ever has been a native feature. (Perhaps a Ruby script may be out there “in the wild.”)

Mac editions (and versions 2016 and earlier on Windows,) had a “Window > Hide Dialogs” command that could be assigned a shortcut. It toggled the display of the floating tool inspector windows.

It was removed on Windows editions with (v2016+) the implementation of the trays and panels.
You can assign shortcuts to toggle trays, as when created they’ll appear in the “Window” menu.


#6

I found a solution. Turn off every toolbar and button, then rely only on shortcut keys. Now it’s screaming fast. Of course, I have to memorize the 124 new shortcut keys I had to create, but I’m sure that’s just a minor inconvenience for most people.

… ugh.


#7

Out of curiosity, do any Sketchup developers actually monitor the forums, or do I need to contact them directly somehow? I’m still having the problem as mentioned in the original post, and now that my Sketchup 2016 License expired, I’m dead in the water. This is ridiculous.


#8

using a remote control software (which is interfering the display driver) is never a good idea in connection with OpenGL (or MS Direct3D) based applications as e.g. 3D modelers like SketchUp… adhere to the SU system requirements which do not support remote desktop connections and disable ‘Dameware’ until using SU.


#9

I’m not running Sketchup through a remote connection. I’m running it straight from my work station. The problem only exists in Sketchup 2017 when too many toolbars/plugins are installed. That’s the issue.


#10

If you purchased 2017, contact support at https://help.sketchup.com/en/contact/technical-support

We monitor here for general problems and issues, but let the support group come to us for specifics.


#11

it’s already sufficient if installed and running in the background as e.g. a service intercepting the OpenGL calls, disabling the remote control software for testing purposes shouldn’t be a big thing.


#12

We’ve removed the remote control software, and the problem persists. If I remove all toolbars, it runs smooth as silk. As soon as I add the toolbars back, it goes to a crawl and the processor usage skyrockets in Sketchup, even when minimized.


#13

In your earlier posts you refer to plugins. Which ones do you use? Some, especially rendering plugins, are resource hogs.


#14

I just removed every plugin, minus the default plugins, and it’s back to running smooth. I installed the Twilight Renderer plugin just now to see if it caused any issues, but things are still running super smooth.

I started adding each plugin one-by-one, and with each plugin added, the processor usage would go up about 1 to 2 percent. I just finished installing all of the plugins I had before, and it’s back to 50% processor usage on 2 of the 8 processors. Two other processors are running at about 40% usage. No single plugin appears to be the issue.

Every plugin I’m running is straight from the extension warehouse.

I just tried installing all of the same plugins on a different system, and the processor usage isn’t spiking on it. At this point I’m clueless.


#15

Try switching off the renderer. Exit SU. Reboot. Restart SketchUp.


#16

I was having these issues way before installing the Twilight renderer. It was only installed last week after my Sketchup 2016 license expired.


#17

Well in order to find the culprit, you have to play the elimination game. (Usually this is done in a binary manner. disable half extensions & restart. IF the issue is still present disable half of those still active, repeat, etc. When the issue disappears, you switch to testing the other “half” of the last set. etc.)

* You can also do this binary testing with the toolbars. hide half, etc. (Toolbars can be programmed by coders in a very poor way that causes the GUI redraw time to take longer. If we can find which ones are the worst, we can teach the coder how to code their toolbars better.)

Was SketchUp installed by right-clicking and choosing “Run as administrator” ? (This is necessary even if logged in as a user with admin privileges.)

The other thing to try is update or rollback the graphics driver.


#18

Every plugin is the culprit, as each will add a percent or two to the processor usage when enabled. if I remove half of the plugins, half of the processor usage will be reduced. Same when I enable/disable the other half. It almost seems like the window manager that controls the toolbars is what’s causing the issue.

I know that in Sketchup 2016, when rendering with Visualizer or Twilight, the toolbars would randomly flash and turn white while it was rendering, which tells me that each toolbar is its own window possibly with its own sub-process.

I really wish the Sketchup team would just allow us to put ALL toolbars into a single toolbar window that can be moved around without corrupting the layout of the tools. That’s a whole other topic, though.


#19

EVERYTHING in MFC is a window object (or some subclass thereof.) Ie, every button, toolbar, dialog, checkbox, etc.

NOT true. They are simply child windows, in a hierarchy of window objects, with the application window at the root. They all exist within the application’s process.

IF this were true, EVERYONE would have the same issue with toolbars. But we don’t.

I suspect one of 2 things.
Either one of the plugins is causing a memory leak, that affects all subsequently loaded plugins.
Or, there is a issue with the MS VS2015 C++ Runtime library installed on your machine.


#20

This topic was automatically closed after 91 days. New replies are no longer allowed.