Sketchup 2017 lagging


#1

I use a Dell Inspiron 7559 with i7 6700HQ, GTX 960M, 8GB*2 DDR3L ram at 1867MHz, a 250GB SSD with Window 10 installed and a 1TB Hybrod drive with SketchUp 2017. Every time I tried to use SketchUp my laptop would start to overheat and SketchUp would start to lag.Is there any fix to it or I should buy a new computer?


#2

Is you computers fan working?


#3

My computer fans are working at maximum speed. In addition, I am also using a cooling pad.


#4

Is this a desktop or laptop, in other words does it have a second inbuilt graphic card? if so make sure SU is using the Nvidia.


#5

I am sure that SketchUp is using the GTX 960M


#6

To make sure.
Go Window/Preferences/OpenGL and click Graphic Card Details and see what it says.


#7

I use my GTX 960M for all application on my laptop


#8

Did you check? Win 10 updates have a habit of changing what the graphic cards do.

Not always a good idea, if you have two graphic cards you may as well use the lesser card to do some of the mundane work freeing up the better card to work harder on things you really need it for.


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.