SketchUp 2016: Inference updates and feedback

@Bryceosaurus - thanks. That was the piece that I was missing.

Ah… worked it out: the text call-out pointing to the “rotation point” forms a ‘hotspot snap point’ on the corner in question that is on a locked plane (or that’s what the tool-tip says)
If the cursor is “snapping” to this rather than the corner of the geometry (Constrained on Line from Point in the tool tip), then there is no inference line.

Both points over-lap, so if your cursor turns the text blue when moving towards the corner and it’s still blue when you hover over the corner, then you get the locked plane point (and so no inference lines) If your cursor approaches the corner without highlighting the text, then you get the lines/point as you would expect.

please tell me there’s a way to disable this. there isn’t a thing this new functionality does that couldn’t be done with guidelines. Only now I have to reach across the keyboard to hold down the difficult to find down arrow. I would have preferred that trimble address the guidelines and make them NOT colored by layer, which often makes them difficult to see when working within a group, or make them lockable, so I can keep critical lines for continued reference.

a checkbox in preferences to disable this update would be greatly appreciated.

(not that I’ll be able to use either 2015 or 2016 until Trimble fixes the .3ds export bug anyway)

thanks for listening.

Every export case is unique so please report the bugs so that we can log them in the database.


thanks for the response. I’ve tried reporting bugs through that link, but
it requires a serial number - we’re a firm of over 500, and have a network
license, not a serial number. ironic, isn’t it?

@cpeterson_com, I will send you a private message.


I found a serial number. putting together an exhibit now.


Some more feedback on the new functionality of the shift key. I use the shift key a lot in combo with middle mouse button to pan. However since this update I find quite often that after I’ve released the shift key, some random unwanted inference lock has become active and I need to press shift again to unlock it.
Is this expected behaviour or am I just not paying enough attention to what I’m really doing?


it happens a lot with me too. really annoying.
I think it’s to do with the timing of when you press and/or release the shift and when you press and/or release the middle mouse button: it’s normally when I’m working fast that it happens to me… I can’t seem to replicate the behavior when I want to.

1 Like

Yup, having the same issue, needles to say that if you try to work in a speedy fashion, this get’s quite frustrating.

Try to get addicted to the mouse only navigation.

Shift sticking sounds like a bug. Can anyone post steps to reproduce this issue?

I was able to reproduce this sticking inference issue. It broke in the 2016 maintenance release. For reference its filed as SU-34079.

Great catch! Thanks for reporting it!


If I may ask: did the team ever consider to add some sort of a quick-patch solution? For people using SketchUp daily, bugs are annoying. Especially if something gets broken that breaks your happy workflow. Mistakes can happen though - no problem. But its frustrating knowing you will have to wait for quite a while (several months until M2, or half a year until M3 / …) before a fix is implemented.

Just curious.

We don’t have a good solution at this time. If a very serious issue related to security or crashing is found, we will spin a new release to fix it. Unfortunately this issue wouldn’t warrant an emergency release.

We also do heavy testing before any release which includes both automated testing and using beta testers. It’s frustrating we missed this particular issue for the 2016 M1 release in March.

Is there a way to temporarily disable inferencing? I am trying to sketch out a corporate logo with lots of curves and a large circle. Sketch up constantly trying to inference everything makes it frustrating trying to accurately pick a starting point.

1 Like

No. This option has been requested several times before, but to date there is no way.

Make sure you have Length Snapping turned off.

Help! Has anyone found a solution yet? I make complex models and this problem has gotten so annoying I can hardly draw. It is absolutely and totally frustrating!

What exactly do you mean by “This problem”? Are you tracing an image or having issues related to face orientation locking? Or something else?