Shortcut key problem using apostropy key (')


#1

I have the apostrophy (’) key set as my shortcut for the offset tool because it is the same shortcut key I use in my CAD software. Just upgraded to v18 from v8 pro and problem is, for example, when I push pull and want to enter a value of, say, 14’ - when I enter the ’ character to indicate feet - it automatically kicks in the keyboard shortcut for offset. This never happened in V8 but does now - any suggestions? I dont really want to change shortcuts as have had this setup now for many years and am an old dog, cant easily learn new tricks.


#2

I don’t think there’s much you can do. Maybe add a modifier like Option. there have always been certain keys that are considered off limits for shortcuts. Numbers, some punctuation, and shortcuts that are hard coded in the operating system.

I use O for Offset.


#3

The default for oFFset is F, but many people do as you have and change O from Orbit since if you have a three-button mouse or space navigator you almost never activate the orbit tool anyway!


#4

Yes. I would never use a keyboard shortcut to activate the Orbit tool so O for Offset, F for Follow Me. Make it easier to remember.


#5

Annoying that this would change. When I enter M for metres (which is also shortcut for Move) it doesnt do it. Muscle memory being what it is makes these changes a PITMFA


#6

I’ve gotten my baby-duck brain used to the sometimes obscure defaults, such as X for follow-me (eXtrude - beneath the covers it is actually called the extrude tool), Q for rotate (Quaternion for the math fans), B for paint (Bucket), H for pan (Hand - another that one never uses if he has good mouse or space navigator, but what a silly idea to base a shortcut on the screen icon instead of the name or action of the tool!). And why G for “make Component” and command-G (on Mac) for “make Group”? And of course, that great newbie tripper, K for "toggle bacK edges)!

Like @Kerschbaumer, I am probably too far gone to change. But your bindings are more logical!


#7

Do you have smart quotes enabled in the system settings? Maybe that is interfering
I have no problem assigning the single quote to a shortcut, but it pops up as ‘RIGHT’


#8

Dont know about smart quotes and had a look in SU prefereences and could not find. Can you direct me to where they are?


#9

They are system settings: apple icon on the left->Settings->Keyboard->text


#10

Turned off smart quotes and no change