Shape bender extension isn't working

I have SketchUp and the tool is working for me. But i have a friend (doesn’t have access to this forum so I’m asking instead of her) and the tool doesnt work at all. Is there any possible way to troubleshoot this? We tried reinstalling the extension and nothing changed. Here is a picture of her extension manager window.

Thank you very much for the replies.

Upload her model so we can see what she is working with. The most likely reason for it not working is she has the model set up incorrectly.

The fact that it shows as “unsigned” has no bearing on whether or not the extension works. If she is only using that as a determination, there’s really no problem.

1 Like

Hi, thank you so much for the reply, first of all i want to apologies for the typos i had in my post, i have no idea why it was like that. I fixed it now, i guess. Unfortunately my friend isnt okay with showing her model and said I can only show you guys the object i want to bend but isnt working. It says “not responding” as soon as i try to bend it. It stays like that for an hour and nothing ever happens.

I can’t see the setup from the screenshot. In order for the extension work the component has to be aligned with the red axis and the straight line under it needs to be parallel to the red axis as well.

The “Not responding” message does not indicate that it doesn’t work. That indicates that SketchUp is busy processing. That model (from what little I can see in the screen shot) appears to have a lot of complex geometry. Start the extension and give it some time to process. Go eat dinner or walk the dog.

1 Like

I moved the object to an empty and new file but it was the same. I know it has to align with red axe to work, i did all the steps correctly. The thing is i did bending for 4 other objects needed for that project and it worked just fine (took some time but it worked) but for that one it doesnt do anything, we tried 3 computers but no result, even in an empty file with nothing else. I was thinking there is something wrong with the object.

Like I said, it looks like a very complex object with a lot of geometry. It’s going to take time to bend.

And again, Not Responding does not mean that it isn’t working.

Since your friend won’t share the component there’s really nothing more to say.

1 Like

Can you show us the statistics for that object?

1 Like

Sure, it doesnt let me post 2 pictures because i’m a new user but here is 2 i uploaded to imgur.

That coroborates my guess that it’s a complex component with a ton of geometry. Tell her to be patient and let Shape Bender do its thing.


It’s most likely the 3D ivy thats choking SU, does she really need to bend the plants too? Cut the plants and bend the planter alone, then pop the plants back on once it’s done. Position the pants so it looks good enough. Nobody can see that every individual leaf is slightly bent, and they wouldn’t be IRL anyway.

The panels look complex too, those could be swapped out for transparent .png images.

Or just let it run overnight. It’s a whole lotta math.


Alright i’m doing it on my PC and already left it for an hour and still waiting, is it alright if i do other browsing with my PC? it’s only using 15% of my CPU?

Thank you very much for the reply.

i’m waiting and if it doesnt do all of it in a few hours i might have to do the plants separate or not even do them. Thanks for the reply bud, take care :slight_smile:

Yes. You can do other stuff while you’re waiting. I think I would have simplified the component first like EF suggested. You know, when EF talks people should listen.


Alright, thank you once again. Yea we shall listen to EF!

Thanks for the kind words. If you listen to anyone it should certainly be DaveR, he’s one of the rare Masters. I stay plugged in to this community because I continue to learn every day by being here, and I try to help out where I can along the way. Let us know if you were able to get bent. :+1:


hello do you mind telling me why my shape bender couldnt work? i followed every step from those tutorials i watched… but after i put the component to the destination path, it didnt even load at all (where it usually has the loading cursor when its working and on the process, i saw it on the tutorial)…if anything you can help, please… i can send my file if its ok… thank you

Upload the SketchUp file so we can see what you have going on.

railing pattern 2017 2.skp (1.9 MB)
here i have the model that i want to shape bender with the path, i did everything i could but still not working… please let me know if i did it wrong, and i used 2017 sketchup… thank you in advanced

That’s an awful lot of geometry to process. It might work if you give it some time. I expect you won’t like the results if it does work however. The corners of your bent path are in pretty tough shape.

After correcting the path, I would consider dividing the railing into short sections. You don’t need this to be a single monolithic structure. You could manage this with four or five separate components. One for the corners, one each for the long and short sides, and one for the top and bottom ends.

Instead of using shape Bender you might try Flowify.

oh so the cause was the path? and yeah it was required for my project and was from my client :frowning:
yes i was thinking on dividing it, and was trying it but didnt work as well, but i was only dividing into 2 paths… anyways thanks alot, i will try as you suggest first…