Shadow up too high?

I imported this model into a new site plan.
What did I do to create a shadow line that too high?

why is shadow line up.pdf (160.6 KB)

You put your model below SketchUp’s ground plane. In the Shadows panel untick the box for On ground.
Screenshot - 3_17_2022 , 2_37_37 PM

You’re the man! Thx