Selection Toys install problem in SU2014


#1

@thomthom
Hi!
Referring to my message on the Selection Toys extension warehouse page about installing the plugin in SU2014, the error message reads as follows:

Error Loading File C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys/core.rb
Error: cannot load such file -- C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys/core_lib.rb
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys/core.rb:20:in `<module:SelectionToys>'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys/core.rb:13:in `<top (required)>'
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/extensions.rb:197:in `require'
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/extensions.rb:197:in `load'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys.rb:40:in `register_extension'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys.rb:40:in `<module:SelectionToys>'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys.rb:15:in `<module:Plugins>'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys.rb:14:in `<module:TT>'
C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys.rb:13:in `<top (required)>'

Hope you can share any light on this! :smile:


#2

Have you downloaded and installed that latest of Thomthom’s TT_Lib2?
I recall seeing a similar error and after installing his latest Lib2, it seems to have corrected the issue.

http://extensions.sketchup.com/en/content/tt_lib²

Chris


#3

I notice a unicode character in your path (the double-dot o in your name). There were problems with such paths after 2014 was released. You should update TT’s extensions to get the latest versions.


#4

Latest version of Selection Toys doesn’t use TT_Lib.

Btw, Torbjörn, what release of SU2014 do you have? The original or the update?
(Also, I’m not sure if things are lost in your error message, can you edit the post, select the error message and click the Preformatted text button? (Right to the Quote button))


#5

@thomthom I’ve got version 14.1.1282. Marked as preformatted as you said.
Thanks for the other tips! I recently had another problem with a plugin related to the ö… If I changed my user name on my computer (and thereby preventing further problems?), would it mess up all previously installed software using searchstrings including my user name I wonder??


#6

I’m not sure what impacts renaming your user account has. I won’t dare to make a claim.

Though I’m puzzled by this error. I need to try to replicate this. I assume that if you inspect C:/Users/Torbjörn/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/tt_selection_toys/ there will actually be a core_lib.rb file there - despite what the error message says?


#7

I have installed Selection Toys in SU 2014 Pro. It works just fine but I only have the first (4) tools for selection and de-selection - faces, edges, groups and components. All the other tools seen in the screen shot are missing. I have tried downloading from the SU warehouse and Sketchucation, both only result in the smaller tool set. Can anyone help me figure this out? Thanks.


#8

Pic of toolset


#9


#10

Sorry for my late answer, have had att deadline and been a bit stressed. Will answer more quickly from here on.
Yes there is certainly such a file at that location!
/T


#11

That’s ok - we had a big deadline with the release of SU2015 as well! :smiley:


#12

Any more thoughts as to what may be the problem?


#13

@thomthom: I should have done it long ago,but finally came around to creating a user with a non-ASCII user name, and when I started up SU from that account all the plugins I have had problems with except one or two suddenly worked, including this. I guess I thought I had to install and/or customize my applications anew if I made a new account, but turns out you can “simply” copy the folders from the old user to the new (from yet another account…). To figure this out wasn’t entirely easy though, as it took some time to figure out the difference between the user account and a user “profile”, which is what the folder in Windows is called, and my having a swedish language Windows didn’t make it easier.
Turns out the SU Team’s Shapes still has the ASCII problem, which I would have thought might be fixed already, which was one of several reason I thought the problem lied elsewhere.


#14

Well, it is and it isn’t. In SU2014 we upgraded Ruby to 2.0 because it had unicode support. However, after doing that we found that Ruby wasn’t free of unicode issues after all - especially on Windows. There are cases where it can still fail - though it’s usually workarounds. But it’s easy for them to slip past testing.

What’s the STL ASCII issues?


#15

Ah, the Shapes extension - not the STL. My bad. I’ll check it out right now.
I just created a user account with æ in it and reproduced the issue. I’ll try the Shapes extension as well while I’m at it.


#16

hm… I just installed Shapes 2.0.1 and it worked fine.


#17

Maybe there’s a new version out. Hasn’t tried as I now use only my ASCII-account, I’m done taking chances. :smile: