Selection Tool process is slow, unbearably slow

update
windows10
kb4013429
kb4013418
kb4015438

#101

Update on my Sketchup Slow Select Tool after 3 days of COLD boot ( my normal daily action)…
All going well … still no delays using Select Tool on any object.
So did not see same problem recurrence as ceanet in above post.
My fix ( see post above) was the Windows Device Manager Driver update for INTEL HD 4000 graphics driver to the above stated version using Windows Device Manager.

My technical details:

Windows 10 Version: 1607 build 14393.1066
Sketchup 64 bit Version 17.2.2555
Samsung Notebook 15 inch NP900X4C-K01U
INTEL HD 4000 Graphics Driver: 17/08/2015 10.18.10.4276

So from my point of view the problem appears to be fixed.


No response, all short cut keys not working,
#102

Hello
I just reinstall HD4000 driver with an older version
INTEL HD 4000 Graphics Driver: 17/08/2015 10.18.10.4276
and after reboot, Sketchup works fine !
I reboot another time : It works fine always !

I hope this situation will continue …

the previous drivers version is build 4425, and prévious, it was the origin’s HD 4000 Driver (2 ou 3 years old) …

My Windows version is 10.0.15063 (Windows 10 Creators Update)

Thanks for ianr3 for his posts and his informations about his computer ! It was help me a lot !

Best regards


#103

This Problem has reemerged.


#104

This information was good.

The problem is that you cannot entirely turn off Windows Updates in Win 10 (especially not in the Home edition.) All you can do is delay the update. So Windows Update is just going to continue reinstalling the updates you uninstall.

The only real answer is to install “hotfix” updates manually from the Windows Update Catalog.
I posted links above in post 47:

Selection Tool process is slow, unbearably slow


#105

Hi all
I have had the same issue as everyone else after the latest update from MS with SU being incredibly slow but I seemed to have worked a very simple way around it (it’s a surprise to me too!).
As everyone will have different PC’s it worked for me on my Dell Optiplex 7010 running Windows 10 Pro.
I have an Intel HD Graphics card (not sure what the model is).
How I did it……

  1. I went into the Intel graphics control panel.
  2. Clicked on the “3D” icon box.
  3. In “General Settings” there are 4 options:
    Performance
    Balanced Mode
    Quality
    Custom Settings
  4. I ticked the “Performance” setting and applied it.
  5. I fired up SU and all seems to be working fine. Not slow anymore.
  6. I then thought I’ll try putting it back to “Balanced Mode” and see what happens.
  7. Fired up SU again and it all seems to be working normally again.

Simple yet effective! I have no idea how long this will last. I’ve also rebooted and it still seems to be working.

Hope this helps.


Slow select issue on 2015, 2015 and 2016 Make
#106

@cymets, what was your 3D setting in the Intel HD Graphics Control Panel before you tweaked the settings?

In SU, go to Window > Preferences > OpenGL. Click on the detail button show details about your graphics. What does it say?


#107

Hi,
In the Intel 3D setting it said “Application Optimal Mode” was enabled.
The “General Settings” was on Balanced mode before I tweaked it onto Performance mode and then I moved it back to Balanced Mode.
Below are the details through SU about the graphics card:

Thanks


#108

Ive tried to no avail to delete that KB update that everyone is referring, and rolling back my computer to a previous date, and uninstalling the update, and everything is either greyed out or no option presents itself to delete or uninstall the update. I am at a loss. When i try to click on an object with in my model, it lags for about 10 secods before highlighting. Im about to rip my hair out… has anyone else figured out how to get around this barrier of deleting the update?


#110

No, I am the OP… I have yet to find a cure-all for this reoccurring
issue.

I am randomly able to work every other week until my computer decides that
SketchUp doesn’t jive with it’s parameters. It’s infuriating. I have
updated to the newest Creators Update, which worked up until 3 days ago. I
have reinstalled graphics card drivers, which works for a few days… I
have uninstalled updates, which works for a few days… Ultimately I am
unable to work in SketchUp for any meaningful period of time on my Windows
10 machine. The common thread here appears to be the integrated IntelHD
gpu.

SketchUp, Microsoft, Intel, please… make this work again. I am losing my
hair, my time, and my patience with your product.


#111

Honestly, my Modus Operandai for the last 4 weeks has been to randomly
delete windows updates and reinstall my graphics card driver and hope for
the best. Any and every solution I have found has lasted a few days to a
week until the problem rears its head again.


#112

Ive tried everything:

  1. Windows will not let me roll back to a previous state. (the option is grayed out)
  2. Windows will not let me uninstall the specific update (KB4013429) on 3/15/17 where I read in this sketchup forum that others were having the same problem. When I pull up the list of all recent updates from 3/4/17-Present, KB4012429 is not in the list, though it is clearly shown in the history. Even when I try to click to uninstall the other update from 3/15/17, there is no “Uninstall” option available.

#113

Here it is CLEARLY on this history:


#114

Have you tried what i suggested above, yet ?


#115

Hi Dan! I checked your post and I didnt see a suggestion. only articles on how that update was a mess and microsoft is trying to fix it. Whats a “hotfix”?


#116

I posted links at the bottom, that lead to 2 hotfix updates.

Seriously, … do a little bit of research on your own sometimes !


#117

well dan, firstly, thank you for posting/replying. However, i am new to this whole Forum thing, new to sketchup, and new to trying to solve my own problems by researching (which is how i ended up here in the first place). Also, unbeknownst to you, i have spend 80% of my work day researching all the possible alternatives to unistalling updates, rolling back my computer, and learning about graphic cards. I cant tell if youre joking or serious when you said i should "do a little bit of research on your own sometimes !"
Im literally trying my best.


#118

i tried your method. im just not able to install anything. i get this message below


#119

Call it it teasin’, … as all I had to do was type “hotfix” into a Google search and the very first “match” in the list was the definition from wikipedia.org. Looking up the definition of a word, or the meaning of a term is one the easiest things to do on the web.

If you have Pro, you should contact SketchUp Customer Support for help.


#120

So now ( 26 April 2017) even Microsoft is saying hold off on the Creators Update !! What the…!

We really need some Sketchup Engineers coming to this forum to help us out on action/strategy for survival… please … guys?
Microsoft is never coming here.


#121

And what should we do?

(Edit: I worked for Apple, so I think you’ll know what my solution would be and you probably wont like it, even in joking.)