Selection Tool process is slow, unbearably slow

Once again. Windows update > Malfunctioning SU select tool etc.
Restarted 3 or 4 times doing no other massaging and it’s working again.

1 Like

It works!

THANK YOU

KB4074588 seems to have mitigated the slow selection tool process. Am I the only one who sees this?

So far.
KB4074588 was installed on my machine 10 days ago after which the select tool lag returned. I restarted my laptop 2 or 3 times and the lag problem went away and so far hasn’t returned. I don’t know what the cause is as there are other things going on involving my graphics card like movie streaming issues with some providers. SU isn’t the only app on the computer.
The windows update did mention the following:

Corrects mouse delays for devices that incorrectly report the battery level status.
I have no idea if or how that would be related.

You’re very fortunate. It didn’t help my slow selection tool whatsoever.
But thanks for the suggestion.

Fixed for me.

I have been trying forever to find a fix. I am just a hobbyist maker and was trying to get Make to work on my new surface pro. Nope. Nothing. I finally installed 2018 Pro and ran this on the command line, and it fixed it for me.

“C:\Program Files\SketchUp\SketchUp 2018\jsonpatcheditor” Preferences WorkaroundDrawXorRectUseGLFlushNotFlushDraw b true

I have a Microsoft Surface Pro with Intel Graphics 520.

I hope this helps someone. I have spent hours trying to get this to work.

–Rich

2 Likes

Once again.
No recent updates.
Suddenly SU 2017 select tool suddenly began the slow selection issue again after more than a month of no problems.
I rebooted my computer and checked the SU select tool and found it still lagging. I repeated this step 3 times allowing Windows to fully initialize. after the 3rd reboot. It works. I didn’t bother rollling back drivers or updates or any of that stuff. Just rebooted until SU select tool works.
What could the problem be?

I’m glad I’m not the only one seeing this. I thought the Windows update a month ago might have solved the problem, but it recently started again after today’s update. Rebooting seems to be the only answer for me too.

reboot 3 times? Really odd behavior.

1 Like

I was going absolutely stir crazy until I just read your comments… and I’ve just tested it myself, without realising it I have been accidentally doing this for the last couple of days. I’ve uninstalled the latest windows updates and just couldn’t figure out why sometimes the problem would re-occur. I think your absolutely right a quick restart has done the trick for me. It’s definitely hit and miss

1 Like

I wanted to contribute for what its worth (haven’t read every response on this thread, but have read a bunch of other/older threads on this topic).
Surface Book
Microsoft Windows [Version 10.0.16299.309]
Sketchup Pro 18

I had the same behavior as everyone else flocking to these threads is having - selection tool is unbearably slow.
I use my surface book docked with extra monitors, so I kept tinkering with my drivers for those (Intel drivers).
After some testing though, I ended up trying to update my integrated display driver from Intel and it threw a fit saying the vendor uses a custom driver for my computer.

Since Microsoft used custom drivers for the display,I grabbed the latest packaged driver/firmware from their site and it actually seems to have fixed the problem for me.

Surface Book Driver Firmware Update
I installed: SurfaceBook_Win10_15063_1801500_3.msi

Now obviously, if you’re not on a surface book, my feedback is moot, but I’ve seen a handful of people talk about being on this laptop and having the issue.

TLDR: If you’re using SUPro18 up to date, and on a surface book, the latest driver/firmware patch from Microsoft fixed the issue for me. - https://www.microsoft.com/en-us/download/details.aspx?id=49497

OMG!!!
I found a fix for mine (it might be buried somewhere in this mess, but i cant find it)
My laptop actually has two video cards and i tried right clicking on the .exe and i was given the option to “Run with graphics processor X”.
When i picked the Nvidia card all was good!!!
For months i struggled with this.
After that i was able to find out that i could set that video card to the default, so i did!
Goodbye cr@p intel video chip!!!
I am back in business.

1 Like

This has been mentioned many times. Keep in mind that Windows will likely push an update that will change the default back to the Intel GPU. You will have to keep an eye on it.

Ok… not sure what’s changed since I posted my original comment about the surface book update fixing it for me, but things aren’t working again.
Couple thoughts come to mind:

  • Got an update I don’t remember approving
  • I am docked at the office which includes a USB to DVI adapter - so it would be different drivers in play (I’m not working on that display but it is present)
  • The dock itself has its own set of firmware that may be a different version than my at home setup

I’ll play around with it more and see if I end up with anything.

Have been following this for some weeks, trying to unintall, rebooting with no susces.
The computer is brand new, so not much to remove.
But in the end i found a fix, updating the graphic card did the trick. (Intel UHD Graphics 630 (Elitegroup))
Now it is working like a charme.:grinning::grinning::grinning::grinning:

I believe I found the cause of my particular issue (and I don’t think it actually had anything to do with the driver pack I installed as mentioned above - but it’s possible it could have).

I’m using a surface book, and I went back into device manager, and my NVIDIA GeForce GPU was showing an error:
'Windows cannot use this hardware device because it has been prepared for “safe removal” but it has not been removed from the computer. (Code 47)

While this device was showing an error, I suffer the selection tool lag problem (activiating the selection tool freezes the entire program).

To fix Code 47 (on the Surface Book), I detached, and reattached the clipboard/screen (I didn’t reboot, log out or anything else, just detach/reattach).
After doing this, my NVIDIA GeForce GPU device stopped showing an error, and upon relaunching SU, the program was working correctly.

As a test, I issued a command to detach the screen through Windows (rather than the keyboard) and it put my NVIDIA GeForce GPU into error again (Windows is uninstalling this device. Code 21) - immediately SU was slow/unresponsive when using selection tool.

The device fixed itself from the Error Code 21, but the Code 47 required me to detach/reattch the clipboard monitor.

Again, this won’t be useful if you’re not on a surface book, but if you are, take a look at if that device is showing an error code.

I think when I applied the driver pack update mentioned in my original post, it likely forced the device to refresh and clear the code - making it look like the driver was the fix, when in reality, it was probably the fact that the device refreshed and became useable again.

Really can’t understand. No update from MS W10 and Sketchup from day to day jump into “slow select issue”. Reinstalling intel hd 4000 drivers in most of the case works. Sometimes it does not.

This situation is really crazy. Why don’t you patch also the “make versions”?

Using W10 Pro / Intel HD 3000 graphics, this worked for me;

  1. Start -> Intel Graphics & Media Control Panel -> Advanced -> 3D tab
  2. Uncheck Application Optimal Mode
  3. Save
  4. Return sledge hammer to shed

Good luck.

3 Likes

this helped me so much i didnt even think to look! now ive changed the default as well

For those who are on Sketchup Make 2017 and have a Dell Latitude Computer (Intel Graphics Card), I just had to update my Graphics Driver using Dell’s support site.

http://www.dell.com/support/home/us/en/04?c=us&l=en&s=bsd

Fixed the Sketchup Selection tool lag.