Seeing trough walls in big models

Hello
Of some reason I see through parts of the floor, selling and walls even if I don’t want to, anyone know why this happens and how to solve it? I have the camera on perspective but it doesn’t help to change the settings.

Hi. What you’re experiencing is called clipping. Refer to the following article from the SketchUp website: Clipping and Missing Faces