Section Fills ignores hidden faces


#1

When using SU2018’s new SectionFill feature (which is cool, by the way), it appears that hidden faces are ignored for creating section fills. Although, if the “View > Hidden Geometry” is on, then you can see the fill

This is a disappointment for me. I think hidden faces should be used to make section fills whether it is visible or not. I found that in Skalp, it was the only way to get rid of the thick section cut line between two groups which I wanted to have appear as joined.

Does anyone else have any thoughts on what the desired behaviour should be?


#2

Maybe this will work for you. Here is a section

image

And here are the 2 walls. I just hid the edge - not the whole face.

image


#3

I agree completely and have already brought this up with the devs.

In my view the hidden state of a face doesn’t in any way alter the volume defined by that face. It merely decides whether the face should be displayed. The face is still there regardless of whether it is displayed or not.

How fills are affected by the Hidden geometry setting is ever more odd. The closed volumes is certainly not altered by toggling Hidden Geometry. There is already a global rendering option for toggling Section Fill visibility altogether, this should not be affected by the Hidden Geometry option.

I hope this can be patched in a maintenance release.


#4

argh… which edge ? trying to reproduce.


#5

I’ve been trying to create a dynamic component that has multiple dynamic parts. This requires hidden geometry where the parts intersect. Because the parts have hidden lines it won’t allow me to use a section fill on the overall dynamic component.

My expectation was that the fill would still show up, even with hidden geometry.

Hidden Geometry off

Hidden Geometry on


#6

If you wrap your DC in an extra container (component) and Outershell the parts of the DC inside it, then SketchUp would know it should be regarded as one . You would still have the possibility to swap back to the DC in case you decide to alter it.


#7

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.