Screen capture software for extension tutorials


#1

I’ve used Snagit in the past to record tutorials but it has problems. If I select multiple entities (maybe too fast) the normal Sketchup highlighting is sometimes suppressed by Snagit.

Now I’m testing LiteCamHD which doesn’t seem to have that problem.

Does anyone have other recommedations?

Thanks


#2

For still captures I use Screen Captor and for videos, I switched from SnagIt to Camtasia. I like Camtasia because it has a robust editor included.


#4

FastStone Capture is nice. It has many options for screen capturing of images and video. $20 well spent.

http://www.faststone.org/FSCaptureDetail.htm


#5

Thanks all.

I contacted Snagit support, downloaded an update, rebooted, and it seems to be working OK for now.
Since I already own it, I’ll stick with it for now.


#6

DaveR: Further testing of the new version of Snagit reveals that it still has the same problem of sometimes not hilighing selected entities. So I downloaded a trial of Camtasia. It is even worse. The problem seems to occur (and sometimes) when I double click on a face to select its edges. The edges do not highlight!. I can see they are selected by the Entities Info window. But they don’t show up on the screen. Strangely they do show up on the video file when I review it. But since they don’t show up in real time I can’t really demonstrate what I want to.

Have you tried double clicking to select edges?


#7

I recently completed over an hour’s worth of SketchUp tutorial material with Camtasia and didn’t have any problems showing selections no matter how they were done. Perhaps it has to do with your graphics card?


#8

Possibly a graphics card issue. But I had no problem with Snagit before: though on prior videos I never needed to double click or Shift extend selections.
I did some further testing:
Same problem in SU15 and SU16.
LiteCamHD works OK but has no editor.
(I’ve realized I need an editor so I can append many small clips to get final video. Otherwise, one mistake and I have to redo the entire video.)
Waiting for more answers from Camtasia support.


#9

you might want try if disabling the OpenGL hardware acceleration by the GPU helps (“Window > Preferences > OpenGL > Use Hardware Acceleration”)… being slower of course.


#10

or check Bandicam and it’s OpenGL window mode:


#11

PROBLEM SOLVED!
There seems to be a bug in the Sketchup16 Preferences OpenGL Settings.
Sometimes when you check “Use hardware acceleration” it displays the wrong options in the “capabilities list” and no hardware acceleration is used.
Details:
My Graphics card is a NVIDIA GeForce GT 520/PCIe/SSE2.
It supports 3 “capabilities” Numbered as 16, 28, and 40. I use 40.
They differ only in antialiasing.
If I turn off hardware acceleration, The capabilities are numbered 101 and 102.
Check it again and the numbers are 16, 28 and 40.

BUT if I uncheck hardware acceleration and CLOSE the System preferences window.
Open the window again. It shows 101 and 102. Now check the Use hardware acceleration
IT SHOWS two new .capabilities numbered 13 and 63. Click details to see that these options are NOT hardware accelerated (Microsoft NOT Nvidia)

So you think you have hardware acceleration but you don’t.

You have to close the preferences window again and open it to get back to the correct list.

Try it out on your configuration and see if you get similar results. It may be a problem only on some hardware configurations.

Somehow I got set to #63 when I configured my new SU16.
If I’m correct this could be a big problem for the SU16 release.

I checked SU 15 and it had the same problem. But I didn’t make the wrong selection when I configured it.