Scf-openpluginfolder v1 not working in SU2018

UI.openURL(“file:///#{Sketchup.find_support_file(“Plugins”)}”) this code is not working in 2018

It works fine for me.
Any error messages ?
If the line of code is copied exactly from your post, then it fails because of the smart-quotes which are probably ill advisedly substituted by this forum’s software.
The example I show above is protected within ‘code’ tags, so it works when copied.
Since [according to your profile] you are on a PC, then you are unlikely to have smart-quotes set up at all ? - however, on MACs it is often the default setting and then it breaks all manner of things !

If you run the bald ...find_support_file... code separately, then does it return a folder path and is that path correct ?


Thanks for your response
The application I have been using for some time is “scf-openpluginfolder v1” and has been working as expected, but now in 2018 it crashes without error message.
I found (Sketchup.find_support_file “Plugins”) this give me the expected result

The SCF tool opens the Plugins folder in all versions…
Its latest version ships with the SketchUcation Toolset…
However, I don’t think it’s changed since its first release.

It would have been more productive to have posted this issue at SCF, as you now say it’s an error specific to an SCF plugin.
However, I can’t reproduce it anyway !
Works fine for me.
So who knows what your issue is ?
Anyone else seeing this ??

No, it works fine for me in SketchUp 2018, OS X 10.11.6

When you say crash, do you actually mean crash or just that it freezes?

open_dialog and save_dialog tries to open the last opened directory. If it is unavailable, e.g. on a network drive that is no longer available or removable media SketchUp freezes for some time while it tries to access the directory.

When the crash happens sketchup quits and wnat sent the details to sketchup direct… Maybe windows 10 is to blame?

Since others have it working as before, perhaps there is something about your set up that is causing an issue ?

When you installed SketchUp v2018 did you do it the correct way ?

The [only] correct way is…

Close SketchUp if it’s open.
Find its installer exe file [when first downloaded it usually arrives in your Downloads folder ?].
Select the installer exe file’s icon.
Right-click > Context-menu.
“Run as administrator”

If it’s already installed choose “Repair”.

Restart SketchUp and retry…

If it still crashes try the above steps - ensuring you use “Run as administrator” - uninstall SketchUp and immediately reinstall it - this time choosing “Install”.

Any custom files already in your User Plugins folder should be safe when repairing/installing like this.

Installing SketchUp [and any other complex app for that matter] on a modern PC, using any other way can cause all kinds of unexpected flakiness.
Even if you have ‘admin’ powers it is NOT the same as using “Run as administrator”, and all kinds of weird things can happen with permissions between Windows and SketchUp - perhaps crashing it when a folder is opened - in this case ??
Never double-click the installer exe file to ‘Run’ it, if you do then chances are that some permissions will not be set up perfectly…

Please try this correct installation… and report back…

Thanks try what you suggested

Tried the first method and it worked. Thanks very much. Will keep that method in future.
Best wishes

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.