Scenes keep reverting to default background color

Each scene in any SU document I have, when I click on a scene it will revert the background color to the default setting. This has to be a bug. Very frustrating. I am using SU 2017. Any help is greatly appreciated.

The background color is saved in the style. After you change the background, do you click the style’s icon with the circular arrows on it to update the style?

1 Like

click on one of your scenes, then change background color and right click on your scene tab and choose update. It has to be done for each one of your scenes

Sorry, I do update the scene will all settings checked, and the background continues to revert back.

can you send a small file we can give a look at as an example ?

But do you update the style first?

1 Like

Yeah, thanks for checking this. Essentially, I have a background color set to a specific color. I then add the scene. Then when I switch to another scene, that has the same set background color, it switches over to the default color. See attached screengrabs to show you what I mean. Here are the files:

Ahhh, that’s it. I didn’t realize that’s necessary now. It used to be that a scene would use your specific settings independent of the styles. SO I have to create a custom style if I edit any of these.

Thank you!

1 Like

No need to check, slbaumgartner had the fix. Thanks for your time.

yeah I was on it. When you update and a warning prompts, you have to save as new style. No worries !

No, it was always the case. Styles are saved to scenes (Styles as in ‘a set of settings’ of edges,background,watermarks etc.)
If you change a style setting, you do not change the Style itself.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.