Sandbox in 2019 doesn't work


#1

I’m an M&S Sketchup Pro that updated to 2019 today. Upon first launch I began the arduous task of Extension migration (…if you understand that, you’re in the right place!). Logged in and went to My Extensions. Sandbox was showing as incompatible…hmmm. I uninstalled it. Quit. Re-opened. Went to Extension Warehouse for Sandbox and it shows ‘compatible with Sketchup 2019’ so loaded it. To be safe, quit, and re-opened. Tried Tools > Sandbox > From Scratch. I can begin drawing one vector but cannot click to end it’s length. I can type in a value and line freezes. I try drawing the orthogonal length and no trailing line. I tried typing in a value with also no luck. I need to press Escape to get out.

So, Trimble, Sandbox is NOT compatible in Sketchup Pro 2019 for macOS. Please fix asap.


#2

What happens if you use extension manager, log out and back in (if necessary), before loading extensions?


#3

I too saw odd behaviour on first use…

try setting the grid size to 10 cm first and see if it works…

the default was set at >100 m on mine…

john


#4

@Stough

If you open the ruby console dialog (Window > Ruby Console) and use the Sandbox From Scratch tool, are there any errors that come up in the console?

Also, what is your grid spacing size set to?

CD