RTX2080 SketchUp very slow; checkup shows no video ram, win7

Hello,
we have problems with a SketchUp Pro 2019 Windows version and a new RTX2080.

The checkup tool shows no video ram, but I found some hints here in the forums this might be a known bug from the checkup tool.
Anyways SketchUp is way slower than it was with the older GPU (AMD Radeon), but GPU drivers are up to date. Latest SketchUp Update is also installed and GPU benchmarking tools show the expected performance of the TX2080, just SketchUp wont work.

I tried some nvidia settings, but nothing changed.

Any ideas?

Actually, it’s a bug in the system Windows uses to determine GPU RAM. CheckUp just exposes the bug because it reads what Windows writes.

Have you looked at SketchUp’s OpenGL settings to ensure that it is using the RTX2018?

Have you checked with Nvidia regarding the use of this graphics card with Win7?

Win7 64bit seems to be officially supported.
I set SketchUps OpenGl to use RTX2018 in the nvidia settings. Can I configure it within SketchUp as well?

The Checkup tool worked fine on my Windows 7 Pro work machine. Everything passed. I’ll check on my Win 10 Pro PC at home.

OK, little update to this issue: We are still having trouble. We replaced the motherboard + CPU + RAM, new Window 10 Installation and the issue is still around: SketchUp seems slow, especially when opening/sending to layout, turning and zooming is awefully slow, shadows are loaded really slow etc.

Any ideas how to get any further?

Just throwing a spitball here but are you using Norton or Symantec or any other intrusive av programs?

nope, nothing at all on the new machine (yet)!

Do you have another GPU you could test with?

We have a Radeon with 4GB VRAM, works better in this matter!

Just FYI …

https://help.sketchup.com/en/sketchup/improving-performance

https://help.sketchup.com/en/sketchup-best-practices-and-applied-principles

What are the statistics of your test model ?

Are you trying to navigate and model with shadows and textures turned on ?

ensure that SU is running on the dedicated GeForce (“Window > Preferences > OpenGL > Graphics Card Details”) and not on a maybe integrated GPU as the intel HD series.

Try if fiddling around with the SketchUp OpenGL settings helps, i.e. for evaluation purposes switch of the AA as well as the fast feedback and/or big texture size options.

If a desktop with multiple monitors connected, ensure that SU is running on the main screen #1 or better disconnet all other monitors.

We only have one screen connected and OpenGL is active in SU. I’ll adjust some settings and try again. Thx so far…

Have you tried this card in another PC to see if the card perhaps might be bad?

Yes, we are trying to navigate with textures and shadows on. We are aware this needs more performance, but since our direct comparison with the former Radeon card looks better than the RTX2080, we think there should be another issue with SU and the specified GPU.

1 Like