RoundCorner shadow issues

Morning,

I had just started a Vray render on a kitchen I’ve designed and noticed a few weird shadows on the worktop.

I played around with lights endlessly then noticed the surface looked a bit odd even in the SU view… So I redrew the worktop and didn’t use RoundCorner to chamfer the edge and it was fine.

Any ideas what I’m doing wrong?

I would upload the drawing, but I’ve already deleted the offending worktop… so not much to be gleaned from it really?!!

Any insight appreciated, thanks!

Maybe this illustrates it…

Two identical rectangles, one with the top edges chamfered using round corner, and the other without. Otherwise exactly the same. But the chamfered one has a weird shading to the face. This shows up as incorrect shadowing in Vray?

Eh!?!?!

roundcorner problem.skp (68.9 KB)

It’s about the edge properties in SketchUp: soft, smooth and without it.
View > Hidden Geometry

Ah! Thanks!

I think as I’m using a MAC I don’t have the same options under my “Entity Info”, but the RoundCorner toolbar gives the option of altering the edge details… I’ve played with that and it seems to work!

Cheers again!

Why have you divided the chamfer faces? There’s no need for that even with Round Corner or FredoCorner.

The exact layout of the entity info window varies slightly from Windows vs Mac, but if you select a edge those options should certainly be there!

Ha! I haven’t knowingly divided them… sounds like the plot may have thickened?

When you set up the Sharp Corner feature in Round Corner, set the #Seg to 1s. And don’t set borders or corners to softened or smoothed.

Brilliant intel’! Thanks Dave!

1 Like

When you have VRay Next installed, newly created materials receive some Xtra data from the extension, leading to all sorts of strange things.
eg. shadows not receiving etc.

png test.skp (1.3 MB)