Restore sketch up styles pre scene setting


I was working on a file which I had been manually saving as I went (as well as auto save being turned on) whilst playing around with scene setting to send to layout.

All of a sudden, I lost the file.

I managed to find it, but only the version where I had set the scenes. Now, it won’t return my style setting (as in everything is black line, but previously I had all different coloured lines).

How do I restore them?

It depends on how those edges were colored. It may be that you just need to edit the edge color to By Material (remember to update the style after editing) or maybe there’s more to it than just that. It would be easier to guide you if we could see the model file.

Thanks for your reply - in the meantime I worked it out, I had simply not re-selected ‘by material’ in the style settings. So simple, all that stress for no reason!

I do have another issue though.

I have been creating 2D drawings in SU. When ready to send over to Layout to notate / dimension, I cannot seem to set the scale in LO? I know how to do it, and it seems to do it correctly, then when I print my drawing to check the scale it isn’t to scale at all.

Is it something to do with my document set up at printing stage?

CURRENT RR BM.skp (2.2 MB)

Are you setting up scenes in SketchUp with the camera set to Parallel Projection and the appropriate standard view?

I believe so, although I only just taught myself how to do that yesterday.

It seems I have got that right, because my previous issue was that when I was working in LO and needed to go back and make an adjustment in SU, sometimes needing to zoom in and out to make the relevant change, when I came back to LO and updated the model reference it would skew all my dimensions / notations.

So setting up scenes in SU one by one of each drawing seems to have solved this issue, but I still don’t seem to be able to scale successfully once printed.

Also, what should I do here, so that I don’t lose my style settings for the drawing as I set the scenes?

You set the scale for the viewport in the SketchUp Model panel.

Ok I will try that now

It depends. but probably the first or second choice. It depends on the changes you made to the style that results in that message being displayed.

Hmmm I am not sure, but I’ll test it out now.

Unlike yesterday, I have now saved a copy of my file should anything go wrong!

Ok I seem to have this particular issue sorted. Thanks.

Now I am trying the scale example you have demonstrated in LO.

Stand by.

That message comes up if you’ve made a change to the style but haven’t updated the style. If you look at the Styles panel the thumbnail will have a couple of circular arrows over it. If those are changes you want to keep and apply to scenes that already use the style, choose Update the Selected Style. If you want to create a new style instead, choose the first option. Don’t choose the last option and don’t do anything to prevent the warning from showing.

Ah ok, that makes sense. Great, thank you!

You’re welcome.

I sent you a PM. Click on the K in the green circle at the top right of the forum page.

Ok, so I seem to be setting the scale ok in LO, but when I print (I have tried both A4 and A3), the scale is still off.

What paper size did you choose when you started the LayOut project?

I did not know you could choose a paper size - this is what I was looking for as I assumed it would be such a thing.

Yes. LayOut is a paper space thing so you need to choose the correct paper size.

Hello again Dave!

I must thank you again so much for helping me yesterday.

I have another question - I know you explained this yesterday but I did not record it.

I am in layout, adding pages for each new drawing as I go by using duplicate page so that I can transfer my title bar over each time automatically, and use the same margins etc.

However, on each page the info in the title bar needs to be different of course, but when I change one page it changes all pages!

How can I isolate them?