Repeatable crash, trying to search 3D Warehouse, with empty search field

First time I tried this, I got a long list of results from the search. Then a few seconds later, Crash, and popup asking me to describe what I’d been doing.

Reloaded model, as recommended, tried again. Quicker crash this time, without time for any results list to appear.

Tried a third time, first entering a search term. No crash. Cleared search field, search again, no crash.

But then reloaded model, tried fourth time - crash again, with no time for results to show.

confirmed error in renderComponent/getTemplateData

VM2988:215 Uncaught TypeError: Cannot use 'in' operator to search for 'custom_st' in undefined

I should have said I didn’t intend to do this first time, but clicked Search too quickly. Then I got curious to see if it was an accident, or repeatable.

Glad to have it confirmed.

Rest of it works slickly. And better looking than last version of P11 I tried.

Still early experimenting, seeing what’s same as desktop, what not implemented.

A rather embarrassing oversight. Thanks for reporting!

Logged as issue number 565.