Remove Excess Geometry

Hi Guys,

We had some 3D Models created for our product, a bar in a wrapper. I have been sent a .fbx file and used an importer to bring this into sketchup.

I am trying to use thrupaint to add on our packaging but it keeps staggering out of position. After further inspection and finding out about hidden geometry there seems to be loads. Is there anyway to clean this up and hopefully then our packaging will sit nicely on the model.

I have attached the 3D model we have to make it easier to take a look.


I don’t see the model. Likely it’s too large to upload here. You could upload to Drop Box and share the link.

First thing I would do if I had the file is run Thom Thom’s CleanUp3 on it to remove any coplanar edges. You can get that extension in the Extension Warehouse along with the required TTLib files.

You could just use Soften smooth to get a workable surface.

Hi Dave,

Thank you for the quick response, here is a link to check out the model:

Could you confirm if what your saying above would work please.


Thought I would add a screen shot of what I am getting. This should be a a continuous straight pattern

Turn on hidden geometry, use the eyedropper to select from one triangle, turn off hidden geometry and paint the surface.

1 Like

Projected texture

For better results you need to uv unwrap and uv mapping.


On phone so only guessing.

cheers, this has worked for me