Reload Component warning problem

I have a main house file that i save as a component to use in other sketchup templates for layout purposes.

When reloading my house component into other sketchup templates, I am getting this notification “ This component has been edited do you want to replace it with a different file” even though i haven’t changed or edited it inside the template file.

Because of this, i am having to redo all my scenes again as they are not updating properly.

In my saved scenes:
Tags visibility adjusted are still in tacked but anything visibly adjusted in outliner is gone.

How can i fix this and not need to redo all my scenes again?

You mean you have saved the model incl scenes, then have a dummy component in another template file which you wish to reload?
You need to be aware that reloading best works with the model itself, scene visibility (especially active section cuts) won’t work.
Create a dummy component with about the same size of project (you might even have a large face that is hidden), set up the different templates with all the scenes (and tags).
The main house component that you are gonna use for reload should be ‘Saved As’ by rightclicking on it.
Then, you can reload from within the different templates

Yes, I have right clicked and ‘Saved As’ the house component in my main sketchup file. That is the component that I import within the different templates.

In the different template, I am having issues with scenes not updating correctly when I use the outliner for object visibility. Though Tags visibility work.

Is there a fix for this?

Are you mixing different versions?
The outliner visibility came later then your profile indicates
Can you upload (example) files (component and template)

Sketchup 2020
No mixing same version

Will try to replicate it and attach a file

Here is an example video that shows what I am facing and the files used in the video are also attached

Files
Full.skp (23.6 KB) Template.skp (108.7 KB) Test Main.skp (90.2 KB)

Better use a dummy component with another name in the test template. Not the original in the forum folder The original definitions Transformations (Axes, Scaling, path still reside in the Model collection) and thus get’s duplicated (Full#1) The visibility of Object Full is thus not remembered by the scenes.

Are you able to get a scene to update correctly using outliner visibility options when reloading?

I thought you were making templates. The initial ‘Save as ‘ is good, if you want to edit that just edit it in a seperate window and save when done.
In the ‘test file, reload

I do that but it doesnt update the scenes correctly if i use outliner for Object visibility

I’m on my phone, now, can’t make a screenshot’s from a desktop. but if you look at. The entity panel and outliner, you can see that the #1 is added at Full definition. As with the (nested) bottoM and top part, it should work if you just edit the saved component file

In the Vid, it was ‘Saved as’, not just saved…
When using ‘Save As’ (after the initial save and filecreation) you make a duplicate (Full#1) that is stored in the File(name ‘Full’)

Ok i think i get it. Will try it tomorrow and see if that fixes it

Thanks

1 Like

I tried it and still same issue.

As soon as i adjust the visibility in outliner to a scene, I get the same notification of “This component has been edited…” which then means I have to redo the scenes again.

It will be much quicker if you used Tags for this. The outliner insists that you would use the same definition.
Thus, you must dig into the nested hierarchy and then reload.
If you wanna use the outliner, save the whole collection as:

Then, when reloading, dig in to the hierarchy:


Or edit the Working File and save the whole collection.
1 Like

Thanks for all the support, truly appreciated :slight_smile:

Guess have to break it down or add more tags as you have suggested and shown.

1 Like