Rectangle Tool Issue Making strange Fill Face

When attempting to create a rectangle fill shape this happens:

Hard to tell from your image. When you orbit the camera around does the surface “shimmer”? It looks like it could be Z fighting. This happens when you have two surfaces occupying the same location in space.

It does not shimmer when orbiting. even if I delete everything and draw a free rectangle this happens:

Can you share the file so we can analyze what is happening? From the web version you will need to click the little “hamburger” menu at upper left and then select “download” to place a copy on your computer. Then you can drag-drop that copy onto a reply window here in the forum.

Taylor Patio and Pool.skp (8.0 MB)

Your patio surface isn’t flat, as can be seen in my screenshot with Hidden geometry turned on. Tou have probably moved some of the attached edges by a tiny amount. You should learn about using groups and components to prevent this from happening.


Your model is surprisingly heavy, over a million edges. But 90% of the geometry is in the four small round plants.

Got it. Thank you so much!

The most likely source of your issues is that you aren’t isolating collections of geometry using components or groups, and that is causing unexpected intersections between things.

You haven’t made components for any of the separable parts of your model. E.g. the patio surface, the lamp (?), the firepit (?) etc are all made up of loose edges and faces. As a result, the base of the lamp, the base of the firepit, etc. intersect with the surface of the patio. SketchUp has broken the patio surface into a bunch of smaller faces while attempting to handle these intersections. It’s obscured by the point of view in you image, but a large triangle at the front has also been lost.

I’d start by making components of the lamp and firepit so that they cease intersecting with the patio. You may then have to hide them temporarily to heal the holes they have made in the patio. You should also make components for other independent objects in the model.

You can see the hidden lines separating the portions if you use Display->Hidden Geometry from the Display tray at the right edge of the screen (icon looks like a pair of glasses). With them visible, you can erase the edges and the chunks of the patio will join back together - which proves they are co-planar, eliminating that as a cause of your issues. Once the patio is a single face again, it should behave normally, though you may have to re-paint the texture onto it as SketchUp may have chosen to propagate the unpainted state from the gray-blue part onto the painted parts rather than vice versa.

In a spirit of learning, I will also point out some other issues with your model.

Several of the issues stem from trying to make your model “pretty” before it is really ready for that:

  • You have a large number of reversed faces in the model. You can see them as grey-blue if you choose monochrome in the style. They are masked in the style you are using because you have painted them with materials. But that’s why the patio surface around the rectangle is showing grey-blue instead of the block texture: the block texture wasn’t copied onto the fragments when the patio was subdivided and now the reversed face is showing.

  • You have added several elements of “entourage” - that is, decorative elements that aren’t fundamental to the model. These contain enormous amounts of geometry and make your model sluggish to work with. For example the four rose bushes contribute almost a million edges, far more than the total from the entire rest of the model! Always delay placing entourage until the essential parts of the model are finished. And if you do place them early, make them non-visible (best via a tag, but also possible via the hidden flag) while editing the model.