Raster Rendering in Layout


#1

I have been using Sketchup and Layout 8 for several years successfully. Decided I wanted to use the google map referencing and upgraded to Sketchup 2015 and for the most part it works. However, in Layout, the raster rendering does not seem to work, just gives me wireframes. I can render these as vectors and I get simple shading and lose all the nice detail. What am I missing that I get wireframes when rendering as raster? Very odd.


#2

In the past when users have reported this sort of thing, unticking Use Hardware Acceleration in SketchUp’ Window>Preferences>OpenGL has sorted the problem. Try it and then reopen the LO project. Make sure the viewport gets updated.

If unticking the box helps, you may have a look to see if there’s an updated driver for the graphics card.


#3

Crazy as it seems, changing a setting in Sketchup did resolve the problem in Layout. I was having random problems in generating PDFs as well so did not think the graphics driver would do that, but who know. Thanks a bunch!


#4

I just tried this experiment to see what would happen. I have also had problems where raster viewports, lets say something where I want to see hidden line (until Layout gets support for dashed line vector rendering, anything you want with dashes has to be a raster viewport), well the raster viewports don’t always render correctly. Sometimes, maybe even often, I have to unlock the layer, change to some random style to force a full redraw, then switch back to my original Sketchup rendering style. This kind of sucks. So tried the project and immediately noticed that my LayOut and SketchUp modeling gained a certain amount of lag - enough to make that not a real option as far as workflow goes - Layout is already slow enough.

As far as raster rendering, I think there are things you can do to make sure the raster viewports will render correctly - I think you need to make sure you have a scene in sketchup for each raster view. For example, if I want my roof to come through as solid on one sheet, and dashed on another, I should create two scenes in sketchup, each with the proper style applied, then each will be in the full state (not listed as “(Modified)” in the sketchup model window drop-down list where scenes are selected). Then you will have a better chance of them rendering consistently, at least it seems to be that way from my experience.

On another note, this test got me thinking - if the video card makes that much difference in smoothness, what is the right amount of video card? I’ll start a new discussion on that one…