Range Error on opening SU 2016 Pro on Mac El Capitan

I’ve had the Ruby console open for some development work I’m doing, and have just noticed this error on opening a simple existing model:
Error: #<RangeError: integer 140597663418992 too big to convert to `int'> SketchUp:1:in `onOpenModel'

and a similar one on opening a new model:
Error: #<RangeError: integer 140597663418992 too big to convert to `int'> SketchUp:1:in `onNewModel'

Should I be concerned about this?

Could it be from a plugin? But if it were, wouldn’t that show the plugin or class name from the plugin?

I don’t seem to have any problems subsequently, except that from time to time an inference gets permanently locked (usually onto a line) and/or the spacebar stops activating the Select tool, but usually only after quite some time (up to hours) while I’m doing multiple testing runs of the plugin I’m working on.

I can get the Select tool back by clicking on the arrow icon in the Large Toolset, but can only clear the inference lock by restarting the computer - restarting SU doesn’t clear it.

are you on mac, your profiles empty?

it’s from an observer loaded by a plugin, I used to get them when I had 3dConnexion for mac plugin…

the other suspects are any that monitor models, renderer plugins, Trimble Connect and Dynamic Components…

You’ll only get the standard error unless the developer wrote specific code to replace it…

if they do that, they may as well fix the issue and avoid the errors…


Might well be 3Dconnexion driver - have just tried CADmouse, but can’t see how to get its wheelmouse to do the standard SU Orbit from wheelbutton. No response yet from 3D connexion about why this isn’t default for SU settings, and why it doesn’t seem possible to assign it either.

Will try uninstalling 3Dconnexion software and see if the message goes away after that.

Thanks for the tip. I’d no idea where the error was coming from.

Uninstalled, but restarting SU still gives the error. Will try restarting machine next…

Nope, that doesn’t do it either.

I am running SU with a second smaller monitor, using standard Mac OS setitngs to do that.

PS: Got it. The 3D connection driver had also installed a SU plugin 3dxSketchup - disabled that, restarted, and the error has disappeared.

Many thanks. Will mark the issue 'Solved"