Quad face tools challenges

greetings to all wisdom keepers! I am thankful for the help ive been receiving here as I deep dive into this world. learning so much !!! I have been working with QFT and have reached a reoccurring stumping pop up. screen shot attached.
I am working on a terrain, and have several issues that have come up through what I imagine is undated I’s and uncrossed t’s on my part. in trying to fix one of these issues I have these random gaps that have appeared in my terrain that I am trying to patch/heal. Using QFTools i first used the quad analyzer icon to show me what is and isn’t quad face. then selected both the area around the holes and some of the neighboring quads and then pressed the turn triangulated quads to plane quads icon thinking that I would then be able to patch by extending the selected newly formed quad mesh to neighboring mesh (icon)

my result with the middle step of selecting both the holes and the are around the holes is what is screenshotted and where I need clarification of some sort.


my understanding leads me to believe that I have both things referred to in the pop up selected. can someone please enlighten me???

ALSO. any insight as to why the holes showed up in the first place is welcome. previously I meshed a terrain fabricated from surveyors CAD import, to a geo located map using vertex tools, quad face tools, Align edges extension, and sandbox drop for the roads. I believe it was in the last steps of coloring the whole terrain and dropping in the roads the holes showed up, but im not 100% on that.

thank u, in advance

You have selected too much. As the error says, You must select Only two triangles and the joining edge, it will then attempt to find all relevant section like it in the connected geometry.

1 Like

thanx I read it as if it were saying at least that much, I gave that a try and got the same message. I realized though that it doesn’t matter because the white hole has no mesh to select or transform. what I need to figure out then is how to mesh the hole/gap. I can not select it. the edges select the surrounding mesh and not the hole/gap. ill keep tinkering until sound advice save me lol. :crazy_face:

noting here that if I do select all the mesh or one neighboring quad there is one edge that crosses one of the gaps.

Screenshot 2024-02-07 at 7.35.21 PM
Screenshot 2024-02-07 at 7.37.10 PM

a screen shot scrolled out reveals other strange phenomenon of black gaps outlined with white dashes. keep in mind this whole area was part of the fabricated terrain that had already been through quad face tools and was all good to go before it was meshed using align ends extension to the geolocated map. @mihai.s any ideas?

If you generate the terrain using toposhaper instead of sand box you’ll have your terrain made out of quads automatically without having to fix anything.
Heres an screenshot from a terrain made with toposhaper from this thread Modelling landscape areas

good tip ill try working with toposhaper. I may try starting from the beginning of the process because all ive learned about helpful extensions along the way, but none the less I think it would be valuable if anyone had answers on the trouble at hand as I like to know both why things go sideways and how to fix them.

That automatic converter in QuadfaceTools is meant to try guessing which edges should be treated as “quad edges” and which ones should be treated as “quad diagonal” when the mesh topology is already arranged in a pseudo-quad way (the only area in which this condition is respected is the one I highlighted in green).
If you look at the topology of the part I highlighted in red is the less possible workable topology I can imagine. There are triangles alternated with N-gons and holes, so in such cases you can tell without even test it that the algorithm will fail.

As other have suggested, Toposhaper is a really good tool if you already have the contour lines of the terrain. And if you don’t have those, there are multiple tricks to convert an existing triangulated mess to quads.
In this video I showed a simple one.

https://www.youtube.com/watch?v=sLC-9zUMbDI

1 Like

After you have conformed (similar in form) the new terrain over the existing ones, you no longer need quads.
After you drape the road over the terrain, it’s normal for there to be no more quads, and you don’t even need them to move on.

In the first clip, I recommended the method with quads both for speed and because you wanted to learn more.

In the second clip, you can see that you get the same result with native SketchUp tools.

The idea is to get a surface with more faces/vertices to be able to capture more details from the survey surface.

@mihai.s the reason I went back to QFtools was because of the strange holes/gaps that showed up. I thought I could fix them with that but then realized that I couldn’t even select them. I understand that more vertices make more detail. I remember seeing in one of the videos I watched along this journey that there is a way to eventually purge some of them and keep the detail so that SU can load/think faster when implementing new actions. (maybe it was working wit smooth tools) I definitely notices SU slow down under the burden of so many vertices. I am going to revise some of the videos I watched to see if I can find this detail.
when I draped the road there were tons of gaps and unconnected edges that weren’t previously there. I used the edge tools to fix most of them but then there were a few problem children that wouldn’t connect. I tried to draw them in, and one spot in particular seemed like the arc tool would be good to make a good parallel for the road but it wouldn’t work either. I imagine that is because it’s on topo terrain. any ideas of why all the gaps from draping and how to fix them in this scenario? here you can see both the gaps in the terrain that started the thread (still don’t know where they came from), and the missing part of the road (part of which I erased because the drape transfer turned out dirty)

I really appreciate your input and ive learned alot from the introduction to the extensions and watching every video I could find on them as well as the original videos you pointed me to. I am thinking that in my next session I might just start over (again, LOL) with all the new tools on hand and see if I nail it this time. (for learning how to troubleshoot, I am still interested in understanding the problems in the thread)
can you explain the difference of the forum nuance… is the Hobby a different group? :nerd_face: :pray:

thanx for this… yes terrible topology. I see what you are showing me. and look forward to studying you video and working with the Toposhaper extension.