Push-Pull just moves the surface?

THis is interesting…if I select the color tool (bucket) this turns into a color picker (pipette) automatically
If I press Alt the tool turns into a bucket but if I move the mouse the tool turns back into a pipette.

Update: I installed a second mouse and it is doing the same so it is not the mouse driver
Update2: also tried a second keyboard …no luck

I have just tried SKUP 2017 (trial)
Same error…

My guess is something related to keyboard mapping, see if you can get some insight from these two links:

link 1
Link 2

If that would be the case the keyboard will be remapped for everything or everything will be affected
As far as I can tell only Sketchup is being affected

Possibly an installation issue, when you installed SU. Did you right click on the installation file and choose “run as administrator”? At any rate find the installation file , right click on the .exe, select run as administrator, then choose the repair option. See what that does

If that happens in the future, then you might wanna reset your shortcuts. Perhaps move’s shortcut was P (the push/pull shortcut), so it activated the move command when you tried to push/pull.
25%20PM

The software was fine for 4 years … I think it started with an windows update but I am not sure

I am not using any shortcuts just the mouse
I tried to reset all the shorcuts but it did not solve the issue

How are the mouse and keyboard connected to the computer?

If wired try something like SharpKey. If Bluetooth try removing the KB and re-connecting.

I already did the above, as I said I tried a different mouse and keyboard

If software re-mapping (using SharpKey or something like it) the KB does not work I am out of ideas.

giving this a bump before I remove Sketchup from my system and look for an alternative

If you think a Windoze update caused the issue, try removing the updates one by one back to the time the issue started. I really don’t think this is caused by SU. It is almost like a N/O switch is reversed to become a N/C. Have you tried to use the on-screen KB?

I have just realized that some other apps are affected
It seems to be something that comes into play when mouse and keyboard are used together (ex: Ctrl+Mouse Wheel for zoom in), another program is giving me grief right now…

I am upgrading to Windows 10 let’s see if that changes the things or it will give me one more reason for a good headache

problem solved by upgrading to Win 10 Pro …it sucks!

Check your Windows accessibility settings. Windows has some “helpers” that are activated by some keyboard shortcuts that can overlap with things you use in applications or that you can use by mistake. Disable them if you don’t need them.

There will be a major update to Windoze starting to roll out next week. It will be a big improvement to the version you have.

Has this been solved yet? I am having this problem with SU2018 Pro on windows 7. So frustrating!

Read through this thread. The problem was found to be graphics driver issues. Try updating your graphics drivers and make sure your Nvidia card is being used to display SketchUp. You could update your operating system to Win10, too. That helped some users.

Thanks Dave. I have an older AMD card. Radeon HD 5830 to be exact. Its drivers havent been updated since like 2015. =(

I am ordering the parts to do a new build so Win 10 will be whats going on it.

So weird because I have used this same machine for years with all flavors of SU and have had no problems. Weird.

Thanks for your reply