Programs can't run because MSVCRT-RUBY220.DLL is missing


#1

After installing the fluidinteractive bool plugin into sketchup in my windows 7 pro system, when I tried to run either the microsoft accessory calculator, notepad or the snipping tool accessory,
I got a message stating that the program could not run because MSVCRT-RUBY220.DLL was missing from the system. I downloaded this DLL and put it in both the windows/sysWOW64 and the windows/system32 folders to try
to fix the problem but it didn’t. So I restored my system to an earier point in time and the problem went away. I was then able to run calculator, notepad, or the snipping tool. A few days ago I got the "could not
run the program because MSVCRT-RUBY220.DLL was missing from the system when I tried to run the application Meshlab.
At that time placing a copy of MSVCRT-RUBY220.DLL in the windows/sysWOW64 and the windows/system32 folders appeared to resolve the problem. I’m thinking that installing some sketchup plugins cause the problem where
a program can’t run because MSVCRT-RUBY220.DLL is missing. I’ve learned that MSVCRT-RUBY220.DLL is a part of the Ruby interpreter and asssume that sketchup plugins (some) need this.
Can anyone shed any light on this?


#2

SketchUp ships its own Ruby interpreter which is contained in the SketchUp program folder (x64-msvcrt-ruby220.dll). It shouldn neither be missing nor affect other software on the system (especially not calculator etc. which are not dependent on Ruby).

If a plugin uses its own executable installer (instead of SketchUp’s .rbz package), it might do more on your system (install separate part of software, register in the system etc.). If that is the case, it could be that something went wrong.

  • it could have tried to install another copy of Ruby on the system level (because of different file name)
  • it could have changed the %PATH% environment variable or something else affecting the launch of programs that are totally unrelated to Ruby.

Can you give a link to the plugin?


#3

Hi, Aerililius
Thanks a lot for your input.
To reiterate all that I did: I downloaded Fluidinteractive’s Bool plugin from the Fluidinteractive website after I learned from an email from their website that their Sketchup plugins were on sale. The file is named BoolPro-1.0.5.rbz. In Sketchup I used the extension manager to install the rbz file. After it was installed, I tried it and the Bool extension worked fine and looked like it would work great especially with the artisan plugin. But then I found that when
I tried to run the MS accessories calculator, or notepad, or the snipping tool, A message box would appear containing the message “program cannot run because MSVCRT-ruby220.dll is missing from the system”. The window of the program I tried to run, e.g. calculator , would appear but clicking in it produced no response. Right before installing the Bool plugin I was able to use all of these MS accessories successfully. Afterwards I couldn’t.
I may be wrong in my conclusion but it appeared that the installation of the plugin caused the problem.
I downloaded MSVCRT-ruby220.dll from some web site and placed a copy in in the windows system directories SysWOW64 and System32 as info on the site suggested, but it didn’t resolve the problem. I really didn’t think that it would.
I did a windows system restore to the latest restore point available and the problem went away.
I see now that the sketchup 2017 directory contains a dll file named x64-msvcrt-ruby220.dll , but I’m pretty sure that the error message window said msvcrt-ruby220.dll was missing which is what I downloaded and placed in windows directories base. Do you know if sketchkup plugins use the x64-msvcrt-ruby220.dll in the sketchup directory? I’m a retired software engineer but know nothing about Ruby and don’t know how these sketchup extensions fit into sketchup.
I realize that this is a strange problem. I know that the MS accessories would not have anything to do with Ruby. I installed several sketchup plugins that are in the sketchup warehouse and haven’t had a problem with them. The Fluidinteractive Bool was not in the sketchup extension warehouse, so this is why I downloaded the plugin from the Fluidinteractive website.
The fluidinteractive sketchup plugins look like they provide some great functionally which I think should be in sketchup itself. I’m new to sketchup but I’m very impressed with the user interface and the capability it has without plugins installed, but I would like to import human models created in Zbrush, Daz 3d, makehuman and other programs and create some organic forms in sketchup although I realize that sketchup is not well suited to this.
I’ve installed several of the .obj file import plugins and have imported objects containing a fair number of faces but none of these obj importers plugins do a good job of applying the texture files associated with the object file, and it takes an unbelieveable amount of timefor them to import the object files.
I would like to exchange thoughts on sketchup with other sketchup users, with you if you wish. Thanks again for emailing me.
BTY What is derivation of aerilius?
Best regards


#4

Lesson learned. Never do this, despite what these “quackery” file library sites say. These sites are just “clickbait” to get people to go there so that their ad banners are displayed.

Only system library files are ever installed into the system folders. Applications do not need to put their libraries there, they can be loaded from the application’s folder. IF the application needs a common system library, it’s installer can call a Microsoft web installer to install the system library direct from Microsoft. (The C runtime libraries are an example.)

Your’e a genius! It’s not rocket science. Yes 2 + 2 = 4. (Yes I’m kiddin’.)
It’s obvious this plugin is causing problems. If you paid money get a refund.

Yes, SketchUp loads this library as the internal interpreter when it first loads up. Plugins do not need to load it as SketchUp does it. This edition of the DLL is specially tweaked and compiled to run inside SketchUp.

SketchUp now only comes in 64bit builds.The filename "msvcrt-ruby220.dll" would indicate a 32bit build of the Ruby interpreter which cannot be used by SketchUp 2017.

This is a big tipoff that something is wrong with this message.


#5

We just released a new version fixing the issue, you can download it from your license manager, accessible through the button “Manage Licenses” in your purchase confirmation email.


#6

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.