Problems with Cut Opening in a DC with subcomponents that I thought should cut, but don't

I’ve developed a DC in SU 2020, then backsaved it to SU2014 to make it more widely usable.

It models Kreg Pocket Holes and screws, with DC Option choices for thickness of board (which governs where the hole should be drilled so the screw emerges about half way down the thickness of the board it is screwing into), and for screw length.

See the thread Modelling Kreg pocket screw holes and screws which is getting far longer than it should have, because I keep running into problems. Claire Z (@EosDawn) was very helpful in stimulating me to make my original overly simple approximate model geometrically accurate.

Here’s the 2020 version of the model, using the Component/Save As r-click option to preserve the outer wrapper of the component. To test it, import it into a new file, don’t open it.

Kreg pocket holes and screws DC v2020.skp (260.1 KB)

It has several problems. They are if anything worse, if backsaved as I originally intended to v2014 - two DC-related errors are triggered when you import the component into v2014, then select the component to move it or explode it, I thought later perhaps this is because the DC Extension in SU202 is v1.7, whereas earlier versions are only v1.6. I only have SU 2014 Make, so can’t create or change the Attributes directly in that version.

  1. When dragged out from the component window, the insertion point isn’t where I (thought I had) set it*. It should be placed on the edge of a board by the guide point in the plane of the pocket hole’s oval opening. It never came out with that point at the centre of the Move cursor, even when that is the origin, for a 1 3/4" (44mm) board thickness. Sometimes, it won’t even let me pick the guide point to move it again, especially with the DC Options set for other thinner boards it always inserts it at the top level DC component origin point.

  2. Both the top level DC component, and a next level subcomponents for different board thicknesses (the pocket holes) are set to Glue to Any, and Cut Opening. Their Cut Opening plane is set with its origin at the insertion guide point for that board thickness, and in the plane of the open end of the pocket hole.

The largest board thickness (44mm) which has its guide point at the origin of the DC will (sometimes) cut an opening. So far, I can’t get other board thicknesses to do so at all.

Am I right in thinking that a sub component inserted in the correct plane should ‘cut an opening’? (I know it doesn’t make a hole in the geometry of the face it is supposed to cut, just appears to make it transparent inside the opening).

Or maybe it isn’t supposed to, and only a top level component can ‘cut opening’? If that is the case, then this DC can’t work, and I’ll have to think of a different way of doing it, with each board thickness having a separate component, perhaps each one being a separate DC with a choice of screw lengths.

Any advice on how to get this to work (if indeed it should work) would be much appreciated.

  • Note
    I thought I had set it in the plane of the hole for the thickest board (44mm). But I just discovered that it Isn’t there, but set for an in-between board size, which is why it wouldn’t glue ON the plane of the board, but only with the hole a long way from the face.

The uploaded file now in v2020 has it set as I planned.

I’ve read that thread, and it suggests (I think) that what I’m trying to do cannot work. If I’m understanding it correctly, the inner components will only cut an opening if their parent component is exploded.

And I’m not sure if I can see how to do that (explode the parent component), without creating other more difficult problems with other components hidden by the DC Option(s) chosen - I think they would all un-hide after their parent DC wrapper is no longer there to keep them hidden. But it gives me some help in thinking about it, and a couple of ideas for further experiment.

Thank you.

1 Like

AFAIK, the DCx v 1.6 is rbe encrypted only so it won’t load in SU < 2016.
I’d think SU2014 is limited to v 1.5

Use Aerilius’ Attribute Inspector.

Thank you, Dan.

I think I can see a way forward now.

Well, what I have done is to separate the original DC into a separate one for each board thickness, each with a selection by DC Option of one of four screw sizes, no screw, or screw head only controlled by setting the subcomponents’ Hidden properties.

They were all copied from one edited version of the original, made unique, then modified to delete all but one pocket hole of the right geometry for each board thickness.

Each copy, and each subcomponent pocket hole, are set to Glue to Any, and Cut opening, with their origins in the plane of the hole opening, and a guide point at their origin.

Five of the eight copies DO cut an opening.

I simply can’t get the other three to do so, and I can’t see why they won’t.

I have tried:

  • exploding the faulty components, and recreating them with Glue to Any and Cut Opening selected in the Create Component dialogue, with the origin placed on the edge of the board and in the plane of the hole opening
  • checking by increasing the display precision in Model Info that the guide points and hole openings are actually in the face of the board they were inserted into. Initially, there were tiny discrepancies of less than on ten thousandth of an inch. Now there is a 0.000000 inch discrepancy, and it still won’t cut an opening when dragged from the component browser
  • opening the pocket hole for editing, moving the opening well above the surface and using Intersect faces with model to re-create the hole edges in the plane of the board face inside the pocket hole component
  • saving the component in v2020, closing Sketchup and reopening it, then trying again, with the same result - not cutting an opening,

None of these have worked. I’ve tried at least one or two of these on all three components, and all of them on the one designed for a 1 /2" (38mm) board.

Any other ideas? Here’s the model, with the eight different DCs for separate board thicknesses.

I cannot get three of them to work, despite having made them all in the same way from the same original. Unfortunately, two of them at least are common sizes.

Kreg pocket holes and screws DC v2020.skp (379.9 KB)

[EDIT] I’ve just thought of one other thing to try - copying one of the working ones, repositioning the guide point, lengthening the pocket hole to cut the face and using Intersect faces with model, then repositioning the component origin.

Why is is so inconsistent? Sometimes works, then when it doesn’t, really stubbornly doesn’t, and won’t.

[EDIT 2]
Trying that. One worked. Trying a second one, copied from the same original as before.

Problems. Can’t pick the guide point to move it up 3mm in the copy. Hold up arrow to force move on blue, and the thick blue dotted line won’t stay upright, but follows the mouse in any direction.

Save model, close SU and restart computer, restart SU again and reopen saved model.

Same problem with not following blue direction. Eventually, I work out that I have to unglue the component to allow vertical movement, and even to change axes.

Do that. Change axes, extend the pocket hole, Intersect faces with model for the nth time, trim off excess, delete component and reinsert it from the Component browser, and it STILL won’t Cut Opening.

Can anyone else figure out why three of eight components won’t cut opening (as the other five will)?

  1. Why isn’t it working for those three, and if possible, can you make it work for them and save the result for me if successful?
  2. What if anything am I doing wrong in my procedure, which has worked five times, and still won’t work in the other three however often I try to repeat it in variant ways?

FINALLY got it.

The component origins in these three components which weren’t cutting an opening were correct, but their subcomponent pocket holes didn’t have their axes at the component origin, but on the plane of the original from which they were copied, 1.5 or 2mm different in the Z direction. Fixed those, and they now all work, after a couple of hours going round in circles.

Now to see if I can save back to v2014, or whether this won’t go back further than v2016 without problems in use in the 2014 version.

if it works in > v17 your cover most people…


Thanks, John. If I run into trouble in v2014, I’ll just go back to v2017.

In the meantime, here’s an image to show a working version of all of the components from v2020, showing several different orientations of glue to face followed in some cases by a rotation about the component origin, and different screw lengths.

I’ll go back to the original thread, and save back in one or two older versions as well.


Well, not a great success. Even v2017 seems only to use v1.5 of Dynamic Components, and doesn’t even offer Dynamic Components AT ALL in a R-click menu on any of my Kreg DCs.

How to get over that? Try to update the DC extension manually in v2017? Update is greyed out in the Extension Manager.

GRRR! Everything about this has been problematic.

SU 2017 had DC v1.5 installed.

I first tried updating it by downloading the latest DC extension v1.7 rbz from the Extension Warehouse and using Extension Manager(EM) to install it, as no update was available according the Manager. [I had it disabled anyway, I realise. Perhaps all I needed to do was enable it?] Then tried to use Install Extension from the EM.

Nothing happened.

So I deleted the file and folder for su_DCs from the plugins folder, restarted SU, and opened EM again. DCs are still there, still disabled, and now reverted back to v1.42!

Try for a third time - rename the rbz file to .zip, unzip it and copy file and folder to plugins, and restart SU.

That eventually worked, when at the second try, I remembered to Apply Changes after enabling DCs.

So that eventually functions, and might have worked even without updating the DC Extension.

Try again, in v2014. That only had v1.3.x of DCs. Try opening the file - seems ok. Enable DCs, and R-click on a component. Get a DC Component Options in the contenxt menu - and up pops the choice of screw. Also so far so good.

Then trouble. Open anything for editing, and two immediate, successive errors - can’t open ANYthing for editing with a double click, but R-click Edit Component works.

And when I install v1.7 DC all seems to work again.