Problem with Saving File- It Shows Message: " CfileException 0 in C:\folder\file.skp " and does not save file

I’ve been going through this forum and it looks like this CFileException…issue has been going on for some time. I did not have this problem with SU17 just SU18. and I’m positive it is due to the Auto Save feature. SU16 had Autosave problems in that when there was crash it didn’t create a file at the moment of the crash. SU17 fixed this. SU18 we are back to the crash and no saved file. I’ve tried everything; it doesn’t matter whether the skp file in in a Local or Dropbox synced/unsynced folder. The CFileException happens regardless. If this is because we have Dropbox or GDrive or any other Cloud based synced/unsynced folder on the computer then this is a problem for Trimble. Fix it! If they want this program to survive in the ‘Real World’ then it has to work in the ‘Real World’.

Yesterday I shut off the Autosave [because of all the CFE’s] and was trying to remember to save regularly then one time, at the moment of the ‘Click’ [to save] it crashed and I lost 2 hours of work. I send in at least 10-15 bug splats per day. I have another Autosave issue I will post on a new thread where when you are push/pulling a face and AutoSave kicks in with the blue wheel of dread spinning. when its finished the push/pull surface is now twisted and distorted and 100 miles long. You have to open a backup copy to fix it.

1 Like

Thanks Randy, for reporting on this CFileException problem. I have been dealing with it for a couple of years now. However, I think we are a day late and a dollar short, Trimble is no longer interested/supporting SU17. They have pretty much moved on it seems and for those of us who are sticking with the local program, we on our own!.

not very suprising w/ SU v2018 released in November 2017… there is no liefetime guarantee for an endless backwards maintenance of ol’ versions… especially not for the non-commercial, non-revenue-generating Make version you are probably using.

those of you who are sticking with the local program can always us the latest release, which is maintained as well as supported of course.

ok, if you don’t wanna shell out money you need to live with the issues of previous revisions… obviously.

I have the full Pro version and have been paying my annual maintenance fee for about 10 years now.

I’m also a Accredited Trainer listed on the Trimble website… None of the other 3D modeling programs compare to the speed in which I can model in SU. So I’m stuck in it for better or worse. :wink:

1 Like

Attention All. I no longer have this problem!

If you have installed Trimble Real Works [3D Point Cloud software] UNINSTALL IT.
Problem free since I did.

Hello SketchUp friends! Guz here to monitor the CFileException0 issue. We are narrowing the issue down to applications locking the .skp file during a manual or autosave attempt. This is usually related to overzealous antivirus applications (like AVG) closely monitoring all read/write actions. The short lock time to analyze the file is usually enough to cause the error. Other applications involved in file security during transfer, like cloud backups apps, local network synch applications along the transfer path can also have a negative impact ESPECIALLY if the files are exceptionally large or if the network speed is lagged / slow.

Now we’re trying to discover which applications are grabbing hold of the file while it’s being saved. That should be possible with a Microsoft tool called Process Explorer (

If you are experiencing a CFileException error and are comfortable with experimenting with Process Explorer, would you mind launching it the next time you are getting that error? If you want to participate in this research but are not comfortable with using Process Explorer, let me know and we can try to schedule a remote access session where we can take a look at it for you.


1 Like

Hi Guz,

I’m glad you’re looking into this. I just installed Process Explorer and have it open while I did what I know creates the CFileException0 error. Not sure what I’m looking for in Process Explorer though. Do you want to look?

1 Like

Hi Dave! Sorry for the late response, I was out for the weekend. I would love the opportunity to have a look at Process Explorer during a CFileException0. I’ll see if I can arrange a time that works for you to remote into your computer.

1 Like

I too just started getting this message and I think I found a solution, (at least it seems to have solved my issue). Go into the Program Files>SketchUp folder and rename the file sketchup_webhelper.exe to sketchup_webhelper.exe.old. I no longer have this error, Process Explorer found it running.

I would be interested to hear what this execuatable is doing exactly anyhow?

the free ‘LockHunter’ can be helpful for evaluating the issue too.

to the wild: be aware, that file locks are typically created because of a reason, killing them might lead to undesired results.

1 Like

The webhelper file is to allow SU to communicate with the extension manager, warehouse and 3d warehouse. When disabled you will not be able to connect.

But I might have jumped the gun, I re-enabled my webhelper file and the issue was gone, though I believe now the issue is with a graphic driver. My Dell G3 has two graphic cards, a GeForce GTX 1050 Ti and an Intel 650. When I disable the Intel driver I get all kinds of wierd issues that as of today are unanswered.

doubt this, file operations are typically not related to the used graphics card driver.

the free ‘FileLocker’ command line tool might help to evaluate this issue.

If file locking a SKP document and trying to open SU asks to open as “read-only”, if confirmed am getting a “CFile Exception 11” and nothing happens.

1 Like

Well, yes with previous versions of Windows. However this new 1809 version plays havoc with all sorts of permissions and capabilities of non OEM drivers and hardware. I only started to suspect this when i ran into problems with Kerkythea, Photoshop and Office with file usage. All of them linked back to the disabled Intel driver.

I have a call into the support dept. at Nvidea, though I doubt they will be able to help.

Wandering if you found a way to resolve this issue - I have the same problem and its very annoying…we might have to consider going to another modelling software.

Update your graphics driver, not through Device manager, go to the manufacture site. All I know is that once i re-enabled the Intel driver all my problems went away.

Tried that - didn’t help…

Let me know if you are using any of the following…
-Dropbox or any other network / cloud storage or backup service
-Antivirus (like AVG)

That might help us narrow down on the issue. What we normally see with a CFileException is something locking the file temporarily, while SketchUp is trying to access the file or backup of the file. It may also be permissions related. I’ve seen situations where a user creates a new user account on their computer, logs in with that new account and suddenly, everything works. It has to do with a corruption in the user profile.