Problem with Saving File- It Shows Message: " CfileException 0 in C:\folder\file.skp " and does not save file

Attention All. I no longer have this problem!

If you have installed Trimble Real Works [3D Point Cloud software] UNINSTALL IT.
Problem free since I did.

Hello SketchUp friends! Guz here to monitor the CFileException0 issue. We are narrowing the issue down to applications locking the .skp file during a manual or autosave attempt. This is usually related to overzealous antivirus applications (like AVG) closely monitoring all read/write actions. The short lock time to analyze the file is usually enough to cause the error. Other applications involved in file security during transfer, like cloud backups apps, local network synch applications along the transfer path can also have a negative impact ESPECIALLY if the files are exceptionally large or if the network speed is lagged / slow.

Now we’re trying to discover which applications are grabbing hold of the file while it’s being saved. That should be possible with a Microsoft tool called Process Explorer (https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer)

If you are experiencing a CFileException error and are comfortable with experimenting with Process Explorer, would you mind launching it the next time you are getting that error? If you want to participate in this research but are not comfortable with using Process Explorer, let me know and we can try to schedule a remote access session where we can take a look at it for you.

Cheers!
-Guz

1 Like

Hi Guz,

I’m glad you’re looking into this. I just installed Process Explorer and have it open while I did what I know creates the CFileException0 error. Not sure what I’m looking for in Process Explorer though. Do you want to look?

1 Like

Hi Dave! Sorry for the late response, I was out for the weekend. I would love the opportunity to have a look at Process Explorer during a CFileException0. I’ll see if I can arrange a time that works for you to remote into your computer.
Cheers!
Guz

1 Like

I too just started getting this message and I think I found a solution, (at least it seems to have solved my issue). Go into the Program Files>SketchUp folder and rename the file sketchup_webhelper.exe to sketchup_webhelper.exe.old. I no longer have this error, Process Explorer found it running.

I would be interested to hear what this execuatable is doing exactly anyhow?

the free ‘LockHunter’ can be helpful for evaluating the issue too.

to the wild: be aware, that file locks are typically created because of a reason, killing them might lead to undesired results.

1 Like

The webhelper file is to allow SU to communicate with the extension manager, warehouse and 3d warehouse. When disabled you will not be able to connect.

But I might have jumped the gun, I re-enabled my webhelper file and the issue was gone, though I believe now the issue is with a graphic driver. My Dell G3 has two graphic cards, a GeForce GTX 1050 Ti and an Intel 650. When I disable the Intel driver I get all kinds of wierd issues that as of today are unanswered.

doubt this, file operations are typically not related to the used graphics card driver.

the free ‘FileLocker’ command line tool might help to evaluate this issue.

If file locking a SKP document and trying to open SU asks to open as “read-only”, if confirmed am getting a “CFile Exception 11” and nothing happens.

1 Like

Well, yes with previous versions of Windows. However this new 1809 version plays havoc with all sorts of permissions and capabilities of non OEM drivers and hardware. I only started to suspect this when i ran into problems with Kerkythea, Photoshop and Office with file usage. All of them linked back to the disabled Intel driver.

I have a call into the support dept. at Nvidea, though I doubt they will be able to help.

Wandering if you found a way to resolve this issue - I have the same problem and its very annoying…we might have to consider going to another modelling software.

Update your graphics driver, not through Device manager, go to the manufacture site. All I know is that once i re-enabled the Intel driver all my problems went away.

Tried that - didn’t help…

Let me know if you are using any of the following…
-Dropbox or any other network / cloud storage or backup service
-Podium
-Antivirus (like AVG)

That might help us narrow down on the issue. What we normally see with a CFileException is something locking the file temporarily, while SketchUp is trying to access the file or backup of the file. It may also be permissions related. I’ve seen situations where a user creates a new user account on their computer, logs in with that new account and suddenly, everything works. It has to do with a corruption in the user profile.

2 Likes

I would add the Preview pane in Windows Explorer to the list.

1 Like

hi guz,

good day,

i have same problem with this error were file are not saving and not functioning the autosave program. also main problem is when going to save manually or save as will making error and file were creating to became temporarily file format. i’m getting damm sucks to this problem could you help me to remote my pc and help to resolve this?

please email me for your reply @ jontomaquin@gmail.com

thank you,
-jonathan

Hi Nathanz!
I can help with that. First off, this CFileException has something to do with your computer’s ability to allow SketchUp to take control of a .skp or .skb file. Things that usually affect this are:

  • Antivirus (AVG used to be a good example) will sometimes lock a file to scan it, during a save or autosave. Most AV applications have a ‘suspend’ option which can be used to see if the CFileException also ceases in that same time period.
  • Corrupt User Account can sometimes break the user access rights to save in particular folders. This can be tested by creating a new user account in your operating system, then logging into your computer with that new account. Under this account you can see if the CFileException stops.
  • Active files (you are working on) that are kept on remote storage (Network drives, cloud storage, backup sync services like Dropbox). Network speed and model size will often exacerbate this particular issue. Be sure that any active file is being saved on a local partition (like your C:/ drive).

We cannot fix those particular issues, that would be the a job for your local IT specialist, but most of what I’ve suggested can be self-diagnosed and successfully repaired pretty easily.

For additional assistance SketchUp related issues, you can use our contact form here: https://help.sketchup.com/en/contact/customer-support

-Guz

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.