Problem with lines on domes

Hello everyone, I’m having a small problem and need some help figuring out where I went wrong. I was working on some dome models. Originally the outside appearances of the domes were smooth. I wasn’t having any problems intersecting them with other shapes.

I corrected some problems in some other shapes in the model and when I went back to continue working on the domes, all of them had horizontal lines. I made sure hidden geometry was disabled. I also tried the smooth tool but it just made the lines more visible.

Right now it’s a big annoyance as I’m having trouble intersecting the domes with other shapes (to create openings), there’s some

Domes used to look like this:

Looks like you have internal faces that need to be remove.
if you attach the model we can check.

I don’t know if that’s the problem because I didn’t have any problem working with them before. There were some domes that I hadn’t altered in a few days that looked smooth about an hour ago, and then suddenly they all looked layered, even the ones I hadn’t worked with.

domes.skp (1.7 MB)

Yep, internal faces.
Internals