Problem with Layout


#1

I’m using sketchup pro 2014. I hardly use sketchup nowadays, so I never bothered upgrading. My problem is that when trying to use layout, when I right click on an imported drawing I get a popup with the options, paste, object snap, grid snap, show grid and render models on page. Im not getting any options to manipulate the drawing or its content on the page! What’s wrong?


#2

How about sharing the LayOut file so we can see what you’ve done?


#3

Ok, here is a screenshot of a newly imported drawing and the result of a right click.


#4

I’ll repeat: how about uploading the LAYOUT file so we can see what you’ve done?


#5

Is that what you meant by sharing the file? I’m new to layout, this forum and its technical functions. I never used layout before, but I was asked to make a presentation for our school, which is why I ventured into it.


#6

I’m asking for the LayOut file. It’s the one with the .layout extension you’d get after hitting Save in LayOut.


#7

The file is too big to send, or so the popup said. What to do?


#8

Upload it to Google Drive or DropBox and share the link.


#9

I’d venture to suggest that you have 2D images imported in your layout doc and the right click options you mention are all that’s available for “manipulation”. If you want to manipulate the “image” in a 3D way you would need to import SKP files into the layout doc (which have an initial view per the saved scene) but a right click will invoke the ability to “Edit 3D view” Maybe that’s the issue?


#10

Ok, here it is! And thanks for your interest!
https://drive.google.com/open?id=1tKmELtPkTUmnbflSCtZhAdQOefln8gEP


#11

It is a 3d .skp file that I imported. I actually sent it from the Sketchup file menu. But I also tried importing into layout, same result.


#12

When I right click on the image I get the sorts of menu entries I’d expect for right clicking on a viewport. After you select the viewport, you can change the scene to the desired one in the SketchUp Model window. I expect you weren’t right clicking on the viewport.


#13

Once I freshly opened the layout drawing with the first scene that I saved in Sketchup and I try to right click, I only get the popup that I mentioned the first time. Nothing else happens. The best I can do is pan the drawing around. It doesn’t select the drawing or do anything else. I checked some youtube vids and they show that right clicking opens up all the options to add new scenes to a page and arrange them. But for some odd reason right clicking does nothing for me. I even tried disconnecting the mouse and using the mac touch pad, with the same result.


#14

Don’t double click in the viewport. Don’t orbit, pan, or zoom the camera in LayOut. Make changes to the view in SketchUp and update the scene. Then save the changes and update the reference in LayOut.


#15

Ok, i’m gonna try. Thanks!


#16

By the way, I can get the same sort of context menu if I right click on the page outside the viewport.
Screenshot%20-%204_12_2018%20%2C%209_45_30%20PM


#17

I quit layout. Went back into sketchup, made sure the scenes were all correct. Saved the drawing and then used the ‘send to layout’ option in the file menu. Layout opened, I immediately saved the file with a name and then with the mouse over the picture itself of the drawing in layout right clicked and got that same old limited popup with the grid snap etc. By viewport I assume you mean the window in layout with the drawing, and clicking only on the drawing and not adjacent to it.


#18

Oh and by the way, when the drawing opens in layout it doesn’t have the blue lines and arrows around it. Its just a plain white paper with the drawing.


#19

T

Yes. What happens if you left click on the viewport? Does the SketchUp Model window display the scene (or Last Saved SketchUp View?


#20

It won’t have the blue board until you select it.