Problem with extents


#1

When I use extents, my screen zooms way out. I suspect I have some kind of object on my template but can not find it. I create a new project, do select all and delete but it is still zoomed way out. I make a small object in the middle and then do extents and it zooms way out again.
How can I find what is causing this?

Thanks for your help.

Rod


#2

One way to do that is to keep track of where your model is. Then after Zoom Extents, drag right to left selection boxes around what you expect to be empty space. Check Entity Info to see what you snagged.

There’s also a known bug in which a text item could be off at a great distance. Have you been using any labels?

I would check the template first, if you suspect it’s part of your default. Open a new file and draw a small rectangle at the origin. Does Zoom Extents zoom out? Or in to the rectangle? If in, you’re good to go for future projects.

If your template turns out to be fine, the fastest fix for your current model would be to copy the model and paste it into a new file.

If the template has an issue, then you should fix or just replace the template before moving on.


#3

If this affects every new file, you are probably right that some remote object was saved in your template. For starters show hidden geometry and make all layers visible to be certain it is not just invisible, as you can’t select things that are hidden. Then try dragging a selection box at each of the corners of the template to see if anything gets selected. If this finds something, you should be able to erase it to fix the file.

Of course, you can also just start over with one of the standard templates, modify it to your needs, and then save it as your new default template.

As always, if you can upload your file here we can take a look at it and most likely tell you exactly where the problem lies.


#4

This happens when I start a new project. It brings up text from an old project and scenes.
I have selected all layers and show hidden geometry. Selected all and delete. Extents still zooms way out.
I draw a 12" by 12" box in the middle of a new files and zoom extents but it still happens.

I do not know how to delete templates or start a new project with a default template


#5

Save a file and upload it here so we can see what is in it.


#6

Open SketchUp and in the Welcome screen, pick a different template than the one you normally use. Make the adjustments you want but don’t add any geometry. Then use File>Save as Template and make sure you select the Use as Default tick box.

As Box suggests, if you upload the file here, we can take a look and clean it up for you. Making a new, clean template is probably the best way to go. You can set up the style, units and camera position to suit your needs.


#7

temp.skp (131.8 KB)
problem file / template


#8

You indeed have suffered the singular text bug in that file. It happens when you attach leader texts to a 2D drawing and then edit the faces of the drawing. The developers are aware of it, so hopefully a fix will be in 2019. In the meantime, the workaround is don’t add leader text to a 2D drawing until you are finished editing the drawing.

Otherwise, that file seems to use an unmodified Architectural Design Style. You should be able to open SketchUp->Preferences and re-select that style as your default. Then open a fresh model and tweak the settings to your liking and save as template.


#9

Thank you for the replies. I have it corrected it now and will note your advice.

Rod


#10

Out of curiosity, if a user has either saved over or deleted the default starting templates that initially installed with the program, is there a place to get fresh copies other than a new installation of SU?


#11

One of the best options is to right click on the original install .exe and choose Run as admin, then when given the option choose, Repair and follow the prompts. This will reinstall all the default templates, extensions etc without changing your custom setup. This can also be used to reset an older version as the default opener if you have tried a newer version and didn’t want it.


#12

I don’t think we can download newer versions of SU. They have gone to web based program


#13

The newest version of SketchUp Make is 2017 and it is still available for download.

sketchup.com/download/all