Problem starting up with SketchUp


#1

Hi!

My name is Catalin and I want to create a 3D model of a town to simulate a real world and then create a optimal traffic controller.

I have installed three versions of SketchUp so far - 2014,2016 and now 2017 Pro, but I didn’t even import a 3d model but it works very slow. I have updated all my graphic card drivers, have followed your suggestions to optimize the app, but still no improvement.

What I must add is that all the controls buttons seems to work properly (speed-wise) but the 3D modelling is significantly slow.

As configuration I have:
Windows 10 x64
Asus R501V


#2

I have runed also the Checkup, results were all successfull.


#3

How about your model: When you look at the Window menu>Model Info>Statistics dialog and check the “Show nested components” box, how high does the Faces and Edges count rise? When these run from hundreds of thousands to millions, SketchUp will start to feel slow, whatever your computer specs.

Anssi


#4

Hi,

I am running just the template model and it works very slow. And as for the number of edges is very small:

Waiting for your answer, thank you!


#5

It might also be related to how you installed it ?

When you installed SketchUp 2017 did you do it the correct way ?

The proper way is to select the installer’s exe file icon and right-click > context-menu > Run as administrator.
Installing it by double-clicking the exe icon or using the context-menu > Run will NOT install it properly and leads to all sorts of glitches and weirdness.
It does NOT matter that your user-account might have admin-powers, those are NOT equivalent to using ‘Run as administrator’.

You can rerun the installer [the proper way] to fix the current installation.
Close SketchUp and ‘Run as administrator’.
When prompted to ‘Repair’ agree.

This should then set up SketchUp properly.
Retest and see if that helps - it can do no harm…


#6

I seem to remember, lately, here, people reporting similar problems to yours under Windows 10 with Nvidia cards. Someone found turning off Fast Feedback (in Window menu>Preferences>OpenGL) helped. Another found installing the newest driver supplied by the notebook vendor (instead of from the Nvidia website) helped.

Have you installed plugins?

Anssi


#7

@TIG I Have reinstalled the application as you suggested but no improvement.
@Anssi Surprissingly unchecking the Fast Feedback solves the my zoom in/out lagging problem. But still the selection of the model runs very slow…

I have not installed any plug-Ins.

I am going to try to install the newest driver driver from the notebook vendor, hope for improvements in this case.

Any other suggestions will be well received, thank you.
Catalin


#8

Hi,

@Anssi: Back with good news, reinstalling my driver solution (not updating) NVidia GeForce Experience solved the problem, combined with the unchecked item Fast Feedback.

Thank you very much for your support!
Beste regards,
Catalin