Problem on price in Generate Report 2018

components

#1

Good morning. I have a problem on the display of prices in the report generates the 2018 version. When the price entered is in thousands, the comma is added, as for decimals. I have entered the prices without commas and decimals. where is the error? can someone help me? Thanks

Update. The problem is generated by setting the comma or dot in the number format in the windows locale. In the Italian version of SU with windows in Italian (comma used to separate decimals) the problem occurs. Changing the settings the report is correct.


#2

Hello,

I’ve got the same problem with the price.
Where do i change the settings for this problem?


#3

Hi, in italian you can change the settings here


#4

Hi ,

Thanks for your quick reply.
I’m on a Mac and i did change the settings but in the generated report i still got the comma after the thousand (2,400).

11


#5

It seems SketchUp doesn’t use the system’s number format in the reports.


#6

Yup. Generate report for prices appears completely broken on non-American systems.

The decimal comma used outside the English speaking countries is not accepted as decimal separator when assigning a price. I must write an American dot to assign decimals. When the report is generated a comma is added as a thousand separator, despite it being against various international standards, and against the system settings, and also being the decimal separator. -_-

2018-01-15_20h02_23
2018-01-15_20h02_32


#7

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.