Problem After Installing the STL extension


#1

Hi Guys!

Sketch Up says I’ve successfully installed the STL extension from Extension Warehouse.
I see the Export STL option under the FILE menu. (Yeah!)
After building a very simple model (Just two boxes) I wanted to try exporting it for 3D printing.
When I click on the EXPORT STL option, a box appears asking for units and File Format (Binary and ASCII). After clicking on the EXPORT button, I see the normal SAVE window asking for directory and file name. I notice that the file extension is not shown. I also notice that no file format options appear under the “Save As Type” pull down menu. So I just add the .STL extension myself. The file (appears) to save and I can see it on my desktop but there isn’t any file type associated with it (No .STL)

Am I missing a step?

Thanks in advance…

Gerry


#2

Mac OS or Windows?

if just the file extension .STL is missing simply rename/add it, be aware that operating systems often do hide file extensions by default.

if the file association with an application is missing but you wanna check if the content was written, just do a “File > Import… > STL”… or check with free netfabb Basic.


#3

You check issues here:
https://github.com/SketchUp/sketchup-stl/issues

One of them (#146) may be causing your “no extension” side-effect.
Update filedialog file extension filter #146

@tt_su, @jim_foltz