Printing Malfunction - No Dialog Box - Odd viewport shows up


#1

When I try to print no dialog box shows up. Instead a small viewport shows up at the lower left hand corner. After this happens I have to do a force quit.

This started to happen when I changed my fonts from the default of 12 pixels to 1" high for text and dimensions. I can print the same portion of the drawing with no problem IF there is no text or dimension. Once I put the text in I do not get a dialog box per above.

Interesting note, the small view in the lower left corner acts as a viewport to the entire drawing. I can zoom or change scenes within that viewport but can not get back to my drawing as normal without doing a force quit.


#2

What OSX version are you running ?


#3

And what model of Mac? Also, to what destination are you trying to print?


#4

Mac Book Pro with OSX 10.10.3

Trying to print to a Canon iP7200 if the dialog box would show up.


#5

I am running 10.10.3 on a Mac Book Pro. If the dialog box would show up
I would try to print on a Canon iP7200.


#6

Hmmm. I see that Canon has a downloadable Mac driver for that printer. Did Mac OS recognize it automatically, or did you have to install the driver yourself? Have you downloaded and installed the latest? Does printing work from other apps?

That little view looks a lot like the print preview from the dialog, but without its surroundings!


#7

My default printer is a Brother MFC 8860 DN and it prints fine from SketchUp as does the Canon iP7200 PROVIDED that it does not have the text on the drawing.

Yes the small view does look similar to the view that would show in the dialog box but the odd way that I can zoom within that view is unlike anything I have seen in SU.

A bit more info to consider. I have used the same set up as above with no problems printing until I changed the font size to 1" in lieu of 12 pixels.


#8

That sure makes it sound like a bug!


#9

which printer is set in your ‘Page Setup’ preferences?

if it’s the Brother, then maybe Canon doesn’t play well with it’s formatting…

just thinking out loud…
john


#10

As a test, I went back and put in new text using the 12 point font size. I could not modify the old 1" text.

The drawing now prints. A bug seems to be in the system. Not sure about the best work around.

In the old days before I upgraded to SU 2015 I kept the font size at 12 point. The font size was not altered in the printing process, meaning whatever I saw on the screen while I worked on the model was the same size font as showed up in the print dialog box and on the actual print.


#11

The best solution always is to export to PDF. Printer driver folks will try to fix EVERY bug that has something to do with PDF. They will not worry about every other app on the planet.

Another option that’s been used on obscure printers is Gutenprint (formerly Gimp Print).


#12

The Brother is set in the 'Page Setup" box. Because I never got a dialog box I could not change from the default Brother to the Canon.

Again, once I changed drawing to eliminate all the 1" fonts and put in 12 point fonts it prints on either the Brother or the Canon.


#13

The problem is I can not get to the print to PDF file option because the dialog box will not open if I have text set at 1".

To get the dialog box to open, I have to go back to the 12 point font here is what it looks like on my screen. GOOD

Now here is what it looks like when the printing dialog box opens up. BAD

This is the same view that shows up in the printer dialog box, a print on either the Brother or Canon printers AND a PDF. BAD

In summary if the drawing has 1" font no dialog box to choose a PDF. If 12 point font then the dialog box comes up but it makes the font size LARGER either in a print on both of my printers and in the PDF. So I have no real work around. :grin:


#14

Not print to PDF; File->Export-2D Image, then select PDF. The other way is going through the print panel. Try that, and let me know what happens. Can you PM me the model or a stripped down version of it so I can try to repro and file a bug? Thnx.


#15

How do you set the font to 1 inch instead of 12 point? In my text properties the Height button is disabled.


#16

after adding, click out of the text context, then back in, it should then toggle between the two…

if your on your mac…

john


#17

That got me further, but it won’t let me go below 10 inches. I am on Mac, so was trying to reproduce your situation.


#18

on my mac, my template set to metres but I can type in 1" to change to that…

I only see it if the view is at an appropriate scale…

john


#19

If I set units to metres I can still only set the same height, 0.254 metres instead of 10 inches.

It could save some time if you posted a simple model that always shows the issue for you. Then when we test it the only thing that has changed is the Mac that it’s being run on, and maybe the OS versions.


#20

I sent you a file via PM.

The print work around came out fine except that I had do export to a .jpg file since my 2D Image option list did not include a .pdf. Unless the print quality is significantly better I will stay with .jpg.