Printing a scaled object at full size on a single sheet


#1

First let me apologize for yet another printing question. I PROMISE I spent a lot of time looking at posts and fooling with settings in dialog boxes.

SU 2016 Make on Windows 10
Parallel Projection and Top camera view

What I’m trying to do is print an oval on 8.5x11 paper to be used as a pattern for Shaker oval boxes. I have been unsuccessful at getting the oval the exact size unless I print a tiled version. But the size of the oval is well within the print margins so I shouldn’t have to tape 4 sheets of paper together.

A curious thing I noticed is that after making the oval, using the Scale tool on a circle, values change in the Entity Info view. When I start with a circle, it shows a Radius parameter. As soon as any scaling operation takes place (squishing or stretching the circle) Radius is replaced by “Length” and it shows the length as ~25 1/4" (or some such large value). So I gather that when I print and get the oval printed the right size (on 4 sheets), what I’m REALLY printing is the 25" thing, even though there are no lines or visible geometry out there. Am I correct in thinking this? Is this the “Viewport” or is that only on the screen? I know the size of the printed object changes as you change the view of it on the screen…

In troubleshooting this I decided to print a simple circle to size and I can’t make even THAT work. No tweaking of checkboxes (Use Model Extents, Fit to Page) nor Scale Values or Page Size have been successful. Trust me, I’ve tried every setting and combination of settings I can think of before consuming your time asking for help. An earlier post gave me hope when it gave specific values for the scale but that turned out to be something of a trial and error process producing approximately correct looking figures. Surely there is a more deterministic way.

Thanks for your help and again, sorry if this is already answered and I just couldn’t find it. I looked!

BTW, I know about Layout but it seems way overkill here.

glenn


#2

Well, since you have tried all combinations I can’t help you with your print-to-scale problem. But I can tell you that the change from “radius” to “length” is because an oval doesn’t have a radius. Also, there is a known bug with how SketchUp calculates the “length” (perimeter) of an oval, so the 25 1/4 value is almost surely wrong anyway. But I don’t think it should affect printout.


#3

Once you scale a circle or an arc unequally it is no longer a circle or an arc; it is a curve, aka polyline, so Entity Info presents you with a different set of data appropriate to the new entity type.

Have you tried changing the window size, and hence the viewport size, so that you exactly crop the ellipse? Any space outside this bounding box appears as margin when you print.

-Gully


#4

Hmmm…I knew it was different info, I just didn’t know what info. Since my drawing seemed to scale enormously when printing, I figured “Length” must be the size of sone non-visible thing, causing the “ballooning”. But length in this case is the circumference of the oval. Never thought of that.

As for resizing the drawing to crop the viewport, I did that with just a plain circle and sure enough the circle printed bigger but still not actual size. However, there may be some combo of settings to go with this and I will investigate. Changing the window size seems like a trial and error deal, though. I’m thinking of using a ruler on the screen to set the circle such that it is actual size on screen, just to see what happens.

In the meantime, why can’t I set the scale values to 1 and 1? That seemed the obvious choice. It’s not at all clear, to me at least, what the meaning of “use model extents” and “Scale” really mean. I read the docs but their consequences are not clear. A 3-D to 2-D issue, perhaps?

Thank you for your help. I truly appreciate it.


#5

I take your problem to be more of getting the object to fit on the printed page than of scaling per se, since you said it scales okay on four tiled sheets. So, really, when I said to “resize” the viewport, perhaps I should have said “reshape” (or both). The idea is for as little of the screen shot sent to the printer (because that’s what a print job in SU is) to be padding as possible. Just to be sure we’re on the same wavelength, here’s my screen resized and reshaped to accommodate an ellipse:

And here’s the corresponding print preview (and I hereby attest that a physical page I just sent to the printer looks just like the preview:

-Gully


#6

Well that’s sure a step in the right direction. Thanks for that. Is the printed elipse the same size as the dimensioned drawing? That is, would a four inch drawn circle be four inches when printed? Obviously, you have shown how to clip away the viewport and that’s a help all by itself.

Gracias!


#7

OK, with the help of Gully Foyle (Danka!) I have this sorted out. I have successfully printed out my oval (ellipse for you geometers) on a single sheet of Letter size paper. The oval as printed is actual size, not scaled in some fashion to fit on the paper or between the margins or some other factor. My printer is an HP Laserjet with appropriate driver. I’m guessing the printer setup is fairly standard. For mine I set it to print 100% of normal size in the page setup dialog. no fit-to-page or any of that. Just print what the application hands you.

The first thing you have to do is shrink the Viewport, which is the size of the window you see on your screen, and presumably, what SU thinks you want to print. If you’re a full-screen window kind of person, click the box in the upper right (between the DASH and the X) to make your window resizable. Then shrink the window by grabbing in the corner or edges of the window until the page count in the Print Preview goes to one. Just make sure you don’t clip off what you are trying to print. This is how you avoid a tiled printout and get your object printed on a single page. Obviously, the object needs to be smaller than the paper size if you want it actual size, as I do here.

As an aside, I tore off the toolbar window and parked it outside the window. No effect whatsoever. The other thing I noticed was that the whole process seemed more sensitive to the horizontal size than the vertical size. Perhaps an artifact of Landscape printing?

The other puzzle pieces are the settings in the dialog box. Don’t worry about page size as that’s the size of the Viewport. UNcheck “Fit to Page” and “Use Model Extents”. Set both “Scale” values to “1” so that 1" of SU = 1" or printout, or to put it another way, “Print Actual Size”.

Click OK to see the result. BTW, don’t be alarmed by the apparent preview when you first get to the Print Preview dialog. On my system, at least, the dialog box comes up superimposed on the PREVIOUS preview. When you click OK, it will redraw the preview with the current settings.

See below for settings that worked for me. Hope this helps someone down the line! And a shout out to Gully Foyle for the help.


#8

The actual glitch here is with the “Use model extents” box. For some reason that doesn’t work for printing objects smaller than about a foot (250 mm) across to full scale. The same object scaled tenfold and then printed to 1:10 scale would work fine. It has persisted through all SketchUp versions.

Anssi


#9

It would also be nice if there were actual user-accessible margin controls.

-Gully


#10

Given issues I’ve seen with scaling, I wonder if scaling up and printing at a smaller scale would give an accurate printout, since the goal is an actual size print. It sounds right but…

Re: margins, I suspect this is a rats nest for developers. I think the smallest margin size, at least, is a function if the printer itself. There are none exposed by my two printers. MS Word provides some control for documents but I don’t THINK you can just print off the edge of the page, on my printer, anyway. I don’t know if an app could interrogate for margin values. But sure as shootin’ it will vary by printer, driver, etc. it would be nice if printing could be abstracted in some way to eliminate everyone from all this fiddling around with arcane parameters. </whiny voice>