Preferences dialog not showing on mac, Orbit snaps +90 about Z


#1

I’ve used sketchup off and on for more than 10 years but in the current version the preference screen does not show on mac osx. On both my mac mini and macbook pro, the same result, no preferences screen. The max mini has dual screens but the macbook pro does not.

The second problem is in Orbit. Rotation about Z snaps +90 degrees. This is very disorienting and a productivity killer.

I’m running sketchup version 8.0.16845. OS is Sierra on both macs. Is there some patch or another version I should be running?

Thanks


#2

What do you see when you open the Preferences window? I see this:

Can you share an SKP file in which this happens to you? From your description it sounds like you aren’t orbiting around the Z-axis but instead, a different axis.


#3

Are you running the current version (17.2.2554) or : [quote=“ma2t, post:1, topic:43720”]
I’m running sketchup version 8.0.16845
[/quote]

trying to run software ‘out of the past’ on newer OS might cause some glitches and quirks, especially in an (Apple) graphic environment . Since you can’t reset the workspace (I believe it also was in the preference panel in version 8) you might wanna try to delete the .plist file of your preferences, location :
~(username)/Library/ Preferences
and delete the file :
com.google.SketchUp.V8.plist ( or, depending on the version you are using : ) com.sketchup.SketchUp.2017.plist

Note : This will reset your entire setup of SketchUp!! It would be like a brand new install, so , maybe someone will come up with a better solution…


#4

Good catch on the version, @MikeWayzovski.

and[quote=“ma2t, post:1, topic:43720”]
I’m running sketchup version 8.0.16845.
[/quote]

are mutually exclusive.


#5

Good call. I had two versions installed. I’m running 17.2.2554. Preferences dialog now shows properly.


#6

carport.skp (265.1 KB)

Here is the skp file giving me problems. Pan works correctly. Orbit first snaps 90 degrees ccw about Z (blue) but after that works as expected.

The Z axis is blue, straight out from the screen I assume.


#7

I also see an initial jump the first time I orbit after opening your file, then everything works normally afterward. I’m not sure why that happens. It may have something to do with the somewhat unusual orientation in which you are drawing (green axis up screen, red across, and blue out toward the viewer - why are you modeling that way?).

You might not have known, as it isn’t discussed much, but SketchUp’s orbit Tool has a notion of “gravity”. As you orbit the model, the Tool tries to keep the red-green plane more or less horizontal-looking in the view, and the blue axis more or less vertically up screen. I suspect that your somewhat unusual orientation of the axes is causing the jump as orbit tries to figure out how to manage gravity. This theory is supported by the observation that if I hold down alt to suspend “gravity” (I’m on Mac, I think the equivalent is ctrl on PC) when doing the first orbit, the model moves smoothly without the jump. But orbit while gravity is live causes the initial jump.


#8

Why is the front facing up on your model?


#9

slbaumgartner, you called it. Orientation was the issue. With blue up, red right the problem is solved. Working model attached. Many thanks!

carport.skp (326.4 KB)


#10

You pegged it. That was the issue. Problem solved!


#11

That was my suspicion yesterday when I asked to see your file. Your description was consistent with having the model incorrectly oriented relative to the axes.


#12

This topic was automatically closed after 91 days. New replies are no longer allowed.